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本マニュアルは，輸出する場合，経済産業省への役務取引許可申請は不要です。 

電話技術相談窓口 

インターネットによる三菱電機FA機器技術情報サービス 
   MELFANSwebホームページ：http://www.MitsubishiElectric.co.jp/melfansweb 
   MELFANSwebのFAランドでは、体験版ソフトウェアやソフトウェアアップデートのダウンロードサービス、MELSECシリーズの 
   オンラインマニュアル、Q&Aサービス等がご利用いただけます。FAランドのID登録（無料）が必要です。 

対 象 機 種  電 話 番 号  受 付 時 間※ 

MELSEC-Q/QnA/A

MELSEC-QUTE 
MELSOFTシーケンサ 
プログラミングツール 
MELSOFT通信支援 
ソフトウェアツール 
MELSECパソコンボード 
AGOT表示器 

シーケンサ一般 
(ネットワーク/インテリジェント機能ユニット以外） 
ネットワーク 
インテリジェント機能ユニット（ネットワーク以外） 
Q00J/Q00/Q01CPU 
GXシリーズ 
SW□IVD-GPPA/GPPQなど 
MXシリーズ 
 
A80BDシリーズなど 
GOT-A900/A800シリーズなど 
MELSOFT GTシリーズ 
プロセスCPU（Q12PHCPU,Q25PHCPU） 
MELSOFT PXシリーズ 
 

月曜～木曜　  9：00～19：00 
　　　金曜　  9：00～17：00

月曜～金曜　  9：00～17：00

052-711-5111 
 
052-712-2578 
052-712-2579 
052-712-2444 
052-711-0037 
 
052-712-2370 
 
 
052-712-2417 
 
052-712-2830

※土・日・祝祭日除く 

FAX技術相談窓口 

対 象 機 種  F A X 番 号  受 付 時 間※ 
※土・日・祝祭日除く 

上記対象機種 9：00～16：00（受信は常時） 052-719-6762

本社機器営業部 〒104-6215 東京都中央区晴海1-8-12（オフィスタワーZ棟15階） （03）6221-2190 
北海道支社 〒060-8693 札幌市中央区北二条西4-1（北海道ビル） （011）212-3792 
東北支社 〒980-0011 仙台市青葉区上杉1-17-7（三菱電機明治生命仙台ビル） （022）216-4546 
福島支店 〒963-8002 郡山市駅前2-11-1（ビッグアイ１７階） （024）923-5624 
関越支社 〒330-6034 さいたま市中央区新都心11番地2 明治生命さいたま新都心ビルランド・アクシス・タワー３４F （048）600-5835 
新潟支店 〒950-8504 新潟市東大通2-4-10（日本生命ビル） （025）241-7227 
神奈川支社 〒220-8118 横浜市西区みなとみらい2-2-1（横浜ランドマークタワー） （045）224-2624 
北陸支社 〒920-0031 金沢市広岡3-1-1（金沢パークビル） （076）233-5502 
中部支社 〒450-8522 名古屋市中村区名駅3-28-12（大名古屋ビル） （052）565-3314 
静岡支店 〒420-0837 静岡市日出町2-1（田中第一ビル） （054）251-2855 
豊田支店 〒471-0034 豊田市小坂本町1-5-10（矢作豊田ビル） （0565）34-4112 
関西支社 〒530-8206 大阪市北区堂島2-2-2（近鉄堂島ビル） （06）6347-2771 
中国支社 〒730-0037 広島市中区中町7-32（日本生命ビル） （082）248-5445 
四国支社 〒760-8654 高松市寿町1-1-8（日本生命高松駅前ビル） （087）825-0055 
九州支社 〒810-8686 福岡市中央区天神2-12-1（天神ビル） （092）721-2247

お問い合わせは下記へどうぞ 
　   三菱電機株式会社 〒100-8310　東京都千代田区丸の内2-2-3（三菱電機ビル） 

MELSEC計装 
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● 安全上のご注意 ● 
(ご使用前に必ずお読みください) 

 

本製品のご使用に際しては，本マニュアルおよび本マニュアルで紹介している関連マニュアルをよくお

読みいただくと共に，安全に対して十分に注意を払って，正しい取扱いをしていただくようお願いいたし

ます。 

本マニュアルで示す注意事項は，本製品に関するもののみについて記載したものです。ご使用いただく

ネットワークシステムの安全上のご注意に関しては，使用するネットワークシステムのマニュアルを参照

してください。 

この●安全上のご注意●では，安全注意事項のランクを「危険」,「注意」として区分してあります。 

 

 

取扱いを誤った場合に，危険な状況が起こりえて，死亡または重傷を受ける

可能性が想定される場合。 

 

取扱いを誤った場合に，危険な状況が起こりえて，中程度の傷害や軽傷を受

ける可能性が想定される場合および物的損害だけの発生が想定される場合。 

 

 

なお， 注意に記載した事項でも，状況によっては重大な結果に結びつく可能性があります。 

いずれも重要な内容を記載していますので必ず守ってください。 

 

本マニュアルは必要なときに読めるよう大切に保管すると共に，必ず最終ユーザまでお届けいただくよ

うお願いいたします。 

 

【設計上の注意事項】 

危険 

● パソコンから運転中のMELSEC-STシステムに対するデータ変更，状態制御は，常にシステム全体が

安全側に働くようにMELSEC-STシステムの外部でインタロック回路を構成してください。 

また，パソコンからMELSEC-STシステムへのオンライン操作において，ケーブルの接続不良などに

よる交信異常発生時のシステムとして処置方法を取り決めておいてください。 

 

【立上げ保守時の注意事項】 

注意 

● パソコンを運転中のMELSEC-STシステムに接続して行うオンライン操作（ヘッドユニットのリセッ

ト，強制出力テストなど）については，マニュアルを熟読し十分に安全を確認の上実施してくださ

い。 

 

● オンラインユニット交換はユニットごとに交換手順が決められています。 

必ず手順通りに交換を行ってください。 

詳細について，入出力ユニットはヘッドユニットユーザーズマニュアル，インテリジェント機能ユ

ニットは各インテリジェント機能ユニットユーザーズマニュアルのオンラインユニット交換の章

を参照してください。 
 

注意 

危険 
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改 定 履 歴 

※取扱説明書番号は，本説明書の裏表紙の左下に記載してあります。 

印刷日付 ※取扱説明書番号 改  定  内  容 

2003年12月 SH(名)-080438-A 初版印刷 

2005年12月 SH(名)-080438-B 一部変更  

2.2節，3.2節，5.1.2項，第6章，8.9節，9.1節 

2006年 1月 SH(名)-080438-C 一部変更  

1.1節，5.3節，第6章，7.6節，7.6.4項，8.1節 

   

 

本書によって，工業所有権その他の権利の実施に対する保証，または実施権を許諾するものではありません。また

本書の掲載内容の使用により起因する工業所有権上の諸問題については，当社は一切その責任を負うことができません。

© 2003 MITSUBISHI ELECTRIC CORPORATION 
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ソフトウェア登録のお薦め 

同梱の「ソフトウェア使用契約書」の内容を承諾いただいたあと，誠にお手数です

が，MELFANSwebホームページ(http://www.MitsubishiElectric.co.jp/melfansweb)に

アクセスし，ソフトウェア登録を行ってくださいますようお願い申し上げます。（登

録にかかる料金などは一切不要です。） 

また，同梱の「ソフトウェア登録証」をFAXまたは郵送していただくことでも登録い

ただけます。 

 

(1) ソフトウェア登録 

MELFANSwebホームページへのアクセス，または製品に同梱されている「ソフトウ

ェア登録証」をFAX，郵送していただくことにより，ソフトウェア登録を行うこと

が可能です。 

ソフトウェア登録後，弊社でユーザ登録を行い，ユーザIDと共に「ソフトウェア

登録確認証」を送付致します。 

また，新製品ニュース，バージョンアップ情報，その他催しなどの最新情報をダ

イレクトメールにてご提供致します。 

 

(2) お問い合わせに際しての注意事項 

お問い合わせの内容はマニュアルで使用されている用語で，具体的かつ明確にお

願い致します。 

問題と思われる現象については，その現象を再現する情報が必要となりますので，

詳しくお知らせください。 

また，パソコンOSや弊社以外の市販ソフトウェアについてのお問い合わせなどは，

それぞれのメーカにお問い合わせください。 
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は  じ  め  に 

このたびは，三菱総合FAソフトウェアMELSOFTシリーズをお買い上げいただきまことにありがとうございまし

た。 

ご使用前に本書をよくお読みいただき，MELSOFTシリーズの機能・性能を十分ご理解のうえ，正しくご使用く

ださるようお願い致します。 
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マニュアルについて 

本製品に関連するマニュアルには，下記のものがあります。 

必要に応じて本表を参考にしてご依頼ください。 

 

関連マニュアル  

 

マニュアル名称 
マニュアル番号 

(形名コード) 
標準価格

MELSEC-STシステムユーザーズマニュアル 

MELSEC-STシステムのシステム構成，電源分配ユニット／ベースユニット／入出力ユニットの性

能仕様，機能，取扱い，配線，およびトラブルシューティングについて説明しています。（別売）

SH-080455 

(13JP39) 
\3,000

MELSEC-ST PROFIBUS-DP対応ヘッドユニットユーザーズマニュアル（詳細編） 

MELSEC-ST PROFIBUS-DP対応ヘッドユニットの性能仕様，機能，取扱い，配線，およびトラブル

シューティングについて説明しています。（別売） 

SH-080435 

(13JP34) 
\3,000
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マニュアルの見方 
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他に下記の種類の説明があります。 

 

 

目的が複合し，基本操作や表示／設定内容だけでは無理な場合に，その応用操作を説明します。 

 

  

   

 

そのページで説明した内容の特に注意する事項や知っておきたい機能などを説明します。 

 

 

本マニュアルで使用する記号とその内容を説明します。 
 

記  号 内  容 

[  ] 

メニューバーのメニュー名を表します。 

[  ]→[  ]はドロップダウンメニューを表します。 

例：[File]→[New]メニュー 

（  ） 
ドロップダウンメニューに対応するツールバーのツールボタンを表します。 

例：[File]→[Save]メニュー（ ） 

“  ” 
ダイアログボックスの項目名を表します。 

例：“File name” 

 
ボタンを表します。 

例： OK ボタン 
 

<<  >> 
ダイアログボックスのタブを表します。 

例：<<Verify All Modules>>タブ 

 

入力送信データおよび出力受信データの各エリアについては下記に示す記号を用いて説明をしています。 

 

(1) データ記号 
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(2) 入力送信データ 
 

データ記号 エリア名 単  位 詳細データNo.の表記 
 

 Br  
 

 
 Br.00  ～  Br.FF  

 
ビット入力エリア 1ビット／1記号 16進数 

 
 Er  

 

 
 Er.00  ～  Er.FF  

 
エラー情報ビットエリア 1ビット／1記号 16進数 

 
 Mr  

 

 
 Mr.0  ～  Mr.127  

 
ユニット有無情報エリア 1ビット／1記号 10進数 

 
 Cr  

 
＊1 コマンド結果エリア 1ワード／1記号 10進数 

 
 Wr  

 

 
 Wr.00  ～  Wr.33  

 
ワード入力エリア 1ワード／1記号 16進数 

＊1：コマンド結果エリアの詳細エリアは，下記に示す記号を使用しています。 
  

データ記号 エリア名 
 

 Cr.0(15-8)  
 

コマンド実行結果 
 Cr.0   

 Cr.0(7-0)  
 

実行先先頭スライス番 
 

 Cr.1  
 

実行したコマンド番号 
 

 Cr.2  
 

応答データ1 
 

 Cr.3  
 

応答データ2 

 

(3) 出力受信データ 
  

データ記号 エリア名 単  位 詳細データNo.の表記 
 

 Bw  
 

 
 Bw.00  ～  Bw.FF  

 
ビット出力エリア 1ビット／1記号 16進数 

 
 Ew  

 

 
 Ew.00  ～  Ew.FF  

 
エラークリアビットエリア 1ビット／1記号 16進数 

 
 Sw  

 

 
 Sw.0  ～  Sw.7  

 
システムエリア 1ワード／1記号 10進数 

 
 Cw  

 
＊1 コマンド実行エリア 1ワード／1記号 10進数 

 
 Ww  

 

 
 Ww.00  ～  Ww.33  

 
ワード出力エリア 1ワード／1記号 16進数 

＊1：コマンド実行エリアの詳細エリアは，下記に示す記号を使用しています。 
  

データ記号 エリア名 
 

 Cw.0  
 

実行先先頭スライス番号 
 

 Cw.1  
 

実行するコマンド番号 
 

 Cw.2  
 

引数1 
 

 Cw.3  
 

引数2 
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総称・略称について 

本マニュアルでは，特に明記する場合を除き，下記に示す総称・略称を使って説明

しています。 

 

総称／略称 総称・略称の内容 

GX Configurator-ST 製品形名SWnD5C-STPB-Eの総称製品名。（n＝1以降） 

ヘッドユニット 製品形名ST1H-PB，MELSEC-ST PROFIBUS-DP対応ヘッドユニットの略称。 

PROFIBUS-DP PROFIBUS-DPネットワークの略称。 

基本分配ユニット 
ヘッドユニットおよび各スライスユニットのシステム用外部電源および負荷用外部電源を分配

するためのユニットの略称。 

負荷用分配ユニット 各スライスユニットの負荷用外部電源を分配するためのユニットの略称。 

電源分配ユニット 基本分配ユニットおよび負荷用分配ユニットの総称。 

ベースユニット 
ヘッドユニットとスライスユニットとの間，およびスライスユニットと外部機器との間でデー

タの受け渡し（配線を含む）を行うためのユニットの総称。 

入力ユニット ビット単位の入力データを扱うユニットの総称。 

出力ユニット ビット単位の出力データを扱うユニットの総称。 

インテリジェント機能ユ

ニット 
ワード単位の入出力データを扱うユニットの総称。 

入出力ユニット 入力ユニット，出力ユニットの総称。 

スライスユニット 
ベースユニットに装着可能な電源分配ユニット，入出力ユニット，インテリジェント機能ユニ

ットの総称。 

MELSEC-STシステム 
ヘッドユニット，各スライスユニット，エンドプレートおよびストッパで構成したシステムの

総称。 

コンフィグレーションソ

フト 

ヘッドユニットおよび各スライスユニットのスレーブパラメータの設定などを行うためのソフ

トウェア。（GX Configurator-DPなど） 
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用語の意味と内容 

本マニュアルで使用する用語の意味と内容を示します。 

 

用  語 用語の内容 

マスタ局 スレーブ局と入出力データを交信するクラス1マスタ局。 

スレーブ局 マスタ局と入出力データを交信する機器。 

局  番 マスタ局およびスレーブ局に割付けられる番号。 

拡張障害情報 スレーブ局で異常発生時に，スレーブ局からマスタ局に通知する情報。 

スレーブパラメータ 
マスタ局で設定するスレーブ局のパラメータ（ユーザパラメータを含む）。 

設定項目については，GSDファイルに記述されている。 

GSDファイル 
スレーブ局のスレーブパラメータが記述された電子ファイル。 

マスタ局でスレーブパラメータを設定する場合に使用する。 

入力送信データ 

ヘッドユニットからマスタ局へ送信するデータ。 

下記データで構成されている。 

・ Br ビット入力エリア 

・情報エリア 

 Er エラー情報ビットエリア 

 Mr ユニット有無情報エリア 

 Cr コマンド結果エリア 

・ Wr ワード入力エリア 

出力受信データ 

ヘッドユニットがマスタ局から受信するデータ。 

下記データで構成されている。 

・ Bw ビット出力エリア 

・指示エリア 

 Ew エラークリアビットエリア 

 Sw システムエリア 

 Cw コマンド実行エリア 

・ Ww ワード出力エリア 

入出力データ 
ヘッドユニットおよびマスタ局との間で送受信するデータ。 

入力送信データ，出力受信データの総称。 
 
 Br.n ビット入力 
 

各ユニットのビット入力情報。 
 
 Bw.n ビット出力 
 

各ユニットのビット出力情報。 

 
 Wr.n ワード入力 
 

インテリジェント機能ユニットのワード（16ビット）入力情報。 

アナログ入力ユニットの場合は，ディジタル出力データ値が格納されている。 
 
 Ww.n ワード出力 
 

インテリジェント機能ユニットのワード（16ビット）出力情報。 

アナログ出力ユニットの場合は，ディジタル値設定データ値が格納されている。 

情報エリア 各ユニットの状態，コマンド実行結果の確認のためのビットまたはワード入力情報。 

指示エリア 各ユニットのエラークリア指示，コマンド実行指示のためのビットまたはワード出力情報。 

入出力占有点数  Br ビット入力エリア， Bw ビット出力エリアで，入出力占有点数分のエリアを占有する。 

スライス番号 

各ユニットの入出力占有点数2点あたりに割り当てられる番号。 

ヘッドユニットから順に0から割り付けられます。（最大値は127となります。） 

コマンド実行時に，実行先として指定する場合などに使用します。 

コマンド 
各ユニットの動作状態読出し，インテリジェント機能ユニットのコマンドパラメータの設定およ

び制御を行うために，マスタ局が実行する要求の総称。 
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製品構成 

GX Configurator-STの製品構成を下記に示します。 

 

形  名 品  名 個  数 

GX Configurator-ST Version 1 (CD-ROM
＊1

) 1 

ソフトウェア使用契約書
＊1

 1 

ソフトウェア登録証
＊1

 1 
SW1D5C-STPB-E 

ライセンス許諾書
＊1

 1 
 
＊1：本ソフトウェアがGX Configurator-DPの同梱品の場合は，各書類はGX Configurator-DPと共用となります。 
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１ 概  要 
MELSOFT

 

１ 概  要 

GX Configurator-STは，MELSEC-STシステム専用のコンフィグレーションソフトウェ

アです。 

 

1.1 特  長 

(1) MELSEC-STシステムのプロジェクト作成 

(a) ユニットの情報を読み出してプロジェクト作成 

MELSEC-STシステムからシステム構成およびパラメータを読み出すことで，簡

単にプロジェクトを作成できます。 
 

 

 
(b) システム構成を変更してプロジェクト編集 

ユニットの追加，並べ替えなどによりシステム構成を変更することで，プロ

ジェクトを編集できます。 
 

 

 

 1 
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１ 概  要 
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(2) MELSEC-STシステムの診断機能 

 (a) MELSEC-STシステムの状態把握が簡単 

GX Configurator-STでは，MELSEC-STシステムを構成するヘッドユニットおよ

びスライスユニットの状態を，モニタできます。 

ユニットの状態をイメージ図で表現しているため，状態の把握が簡単です。 
 

 

 
(b) GX Configurator-STから入出力ユニットまたはインテリジェント機能ユニッ

トのオンラインユニット交換が可能 

オンラインユニット交換では，入出力ユニットまたはインテリジェント機能

ユニットが故障などして交換が必要な場合に，PROFIBUS-DPネットワークを止

めずに，そのユニットを交換できます。 

GX Configurator-STでは，ヘッドユニットのスイッチ操作を行うことなく，

画面に沿った簡単な操作で，オンラインユニット交換ができます。 
 

 

 

 

 1 
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(c) PROFIBUS-DPネットワークに影響を与えることなく出力テストが可能 

強制出力テストでは，ヘッドユニットおよびスライスユニットの Bw.n ビッ

ト出力， Ww.n ワード出力および Ew.n エラークリアビットを使って出力テ

ストができます。 

出力する Bw.n ビット出力， Ww.n ワード出力および Ew.n エラークリアビッ

トは，ユーザが任意に指定できます。 

強制出力テストを行うときは出力する Bw.n ビット出力， Ww.n ワード出力

および Ew.n エラークリアビットのみを使用しますので，強制出力テストで

使用しない出力データは強制出力テストの影響を受けません。 

このため，強制出力テストではPROFIBUS-DPネットワークに影響を与えること

なく出力テストができます。 
 

 

 
(3) スライスユニットのパラメータ設定 

(a) インテリジェント機能ユニットのパラメータ設定 

“Parameter Setting”画面では，ユニットが持つパラメータを一覧表示しま

す。 

パラメータの設定は，この一覧に簡単な操作で行うことができます。 

読出し，照合，エラーチェックなどの機能があり，パラメータの確認も簡単

にできます。 
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(4) 電源容量が足りているかチェック可能 

各ユニットが必要とするDC5V内部消費電流の合計が，基本分配ユニットのDC5V最

大定格出力電流を越えていないかチェックできます。 

電源容量チェックの例を下記に示します。 
 

 

 
(a) No.0のヘッドユニットおよびNo.2～15の各スライスユニットが必要とする

DC5V内部消費電流の合計1.720Aは，基本分配ユニットのDC5V最大定格出力電

流2.000Aを越えていないため，チェック結果が“OK”です。 
 

(b) No.17～40の各スライスユニットが必要とするDC5V内部消費電流の合計2.250A

は，基本分配ユニットのDC5V最大定格出力電流2.000Aを越えているため，

チェック結果が“ERROR”です。 
 

(c) No.42以降の各スライスユニットが必要とするDC5V内部消費電流の合計1.800A

は，基本分配ユニットのDC5V最大定格出力電流2.000Aを越えていないため，

チェック結果が“OK”です。 
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２ システム構成 

 

2.1 システム構成 

MELSEC-STシステムにパソコンを接続した場合のシステム構成を下記に示します。 
 

 

 
＊1：RS-232ケーブルには，下記ケーブルを使用してください。 

 
メーカ名 形  名 問い合わせ先 

三菱電機 QC30R2 － 

－ SC-Q QC30R2 － 

 

 

 

 

 2 
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２ システム構成 
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2.2 動作環境 

GX Configurator-STの動作環境を下記に示します。 
 

項  目 内  容 

 コンピュータ本体 

CPU 
 

必要メモリ 

下表の「使用する基本ソフトウェアとパソコン本体に必要な性能」を参照。 

 ハードディスク空き容量 60MB以上。 

 ディスクドライブ CD-ROMディスクドライブ。 

 ディスプレイ 解像度800×600ドット以上。 

 基本ソフトウェア 

Microsoft R  Windows R 95 Operating System（英語版） 

Microsoft R  Windows R 98 Operating System（英語版） 

Microsoft R  Windows R Millennium Edition Operating System（英語版） 

Microsoft R  Windows NT R  Workstation Operating System Version 4.0（英語版）*1

Microsoft R  Windows R 2000 Professional Operating System（英語版） 

Microsoft R  Windows R XP Professional Operating System（英語版） 

Microsoft R  Windows R XP Home Edition Operating System（英語版） 
 
＊1 Windows NT R  Workstation 4.0使用時は，Service Pack 4以上が必要です。 

 

使用する基本ソフトウェアとパソコン本体に必要な性能 
 

パソコン本体に必要な性能 
基本ソフトウェア 

CPU 必要メモリ 

Windows R 95 Pentium R 133MHz以上 32MB以上 

Windows R 98 Pentium R 133MHz以上 32MB以上 

Windows R Me Pentium R 150MHz以上 32MB以上 

Windows NT R Workstation 4.0（Service Pack 4以上） Pentium R 133MHz以上 64MB以上 

Windows R 2000 Professional Pentium R 133MHz以上 64MB以上 

Windows R XP Professional Pentium R 300MHz以上 128MB以上 

Windows R XP Home Edition Pentium R 300MHz以上 128MB以上 

 

  

   

・ Windows R XPの新機能について 

Microsoft R Windows R XP Professional Operating System，

Microsoft R Windows R XP Home Edition Operating Systemをご使用の場合は，下

記に示す新機能が使用できません。 

下記に示す新機能を使用した場合，本製品は正常に動作しない可能性がありま

す。 
 

Windows R 互換モードでのアプリケーション起動 

ユーザ簡易切替え 

リモートデスクトップ 
 

 

 

 

 

 2 
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３ 機  能 

 

3.1 機能一覧 

GX Configurator-STの持つ機能を下記に示します。 
 

機  能 内  容 参照項 

システム構成の設定 構成するユニットをユニット形名で登録します。 8章 

パラメータ設定 インテリジェント機能ユニットにパラメータを設定します。 8.8節 

オプション設定 
ユニットにラベル名，ベースユニット，および最大入出力点数設定など

を設定します。 
8.9節 

電源容量チェック 
基本分配ユニットのDC5V内部消費電流が足りているかをチェックしま

す。 
8.10節 

システムモニタ ヘッドユニットおよびスライスユニットの状態をモニタします。 10.1節 

ユニット構成，パラメータの書込み

／読出し 

ユニット構成およびパラメータの書込み／読出しを行います。 
9.2節 

入出力データの診断 入力送信データおよび出力受信データをモニタします。 10.3節 

強制出力テスト 

ヘッドユニットおよびスライスユニットの， Bw.n ビット出力， Ww.n 

ワード出力および Ew.n エラークリアビットを，PROFIBUS-DPネットワー

クを止めずに出力テストします。 

10.4節 

オフセット・ゲイン設定 
インテリジェント機能ユニット（ST1AD2-Vなど）に，それぞれの値を設

定します。 
9.5節 

ヘッドユニットのリセット ヘッドユニットをリセットします。 11.1節 

ユニット詳細情報 ユニットの詳細情報およびエラー状態をモニタします。 10.2節 

オンラインユニット交換 
GX Configurator-STから入出力ユニットおよびインテリジェント機能ユ

ニットのオンラインユニット交換を行います。 
11.2節 

PROFIBUS-DPネットワークパラメー

タモニタ 

PROFIBUS-DPのマスタ局からMELSEC-STシステムに送信された，スレーブ

パラメータおよびPROFIBUS-DPネットワークパラメータについて確認で

きます。 

10.6節 

マスタ局との交信データモニタ 
PROFIBUS-DPのマスタ局とスレーブ局（ヘッドユニット）間の入出力デー

タをモニタします。 
10.5節 

 

 

 

 

 

 

3 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

 

 

3 - 2                                         3 - 2 

３ 機  能 
MELSOFT

 

3.2 メニュー一覧 

GX Configurator-STのメニューについて説明します。 

 

  

   

本節のメニュー画面は実際のメニュー画面とは違います。 

実際のメニュー画面では，GX Configurator-STの動作状態により選択できないメ

ニューがありますが，説明のために選択できる状態に変更してあります。 
 
 

[File]メニュー 

 
 

 

 

[File]メニューには，プロジェクトのファイルを操作，印刷

などを行う機能が含まれています。 

 

[New]，[Open]，[Close]，[Save]，[Save As]，[Verify]，

[Print]メニューの詳細は，7章を参照してください。 

[Copy]メニューの詳細は，8章を参照してください。 

[Exit]メニューの詳細は，5章を参照してください。 

[Edit]メニュー 

 
 

 

 

[Edit]メニューには，ユニット構成の設定およびパラメータ

の設定に関する機能が含まれています。 

 

各メニューの詳細は，8章を参照してください。 

[View]メニュー 

 
 

 

 

[View]メニューには，各画面の表示／非表示を切り換える機

能が含まれています。 

 

各メニューの詳細は，6章を参照してください。 
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[Mode]メニュー 

 
 

 

 

[Mode]メニューには，編集モードと診断モードを切り換える

機能が含まれています。 

 

[Edit]メニューの詳細は，4.2節を参照してください。 

[Diagnosis]メニューの詳細は，4.3節を参照してください。

[Online]メニュー 

 
 

 

 

[Online]メニューには，ヘッドユニットへ接続，ヘッドユ

ニットのオンライン操作に関する機能が含まれています。 

 

[Transfer Setup]，[Get System]， 

[Get Input/Output Data Settings]，[Offset/Gain Setting]，

[Parameter Block Write]メニューの詳細は，9章を参照して

ください。 

[Input/Output Monitor]，[Forced Output Test]メニューの

詳細は，10章を参照してください。 

[Reset Head Module]メニューの詳細は，11章を参照してく

ださい。 

[Diagnostics]メニュー 

 
 

 

 

[Diagnostics]メニューには，システムを診断する機能が含

まれています。 

 

[Module Detail Information]， 

[PROFIBUS-DP Network Parameter Monitor]， 

[Master Station Data Communication Monitor]メニューの

詳細は，10章を参照してください。 

[Online Module Change]メニューの詳細は，11章を参照して

ください。 

[Window]メニュー 

 
 

 

 

[Window]メニューには，GX Configurator-STの画面配置を操

作する機能が含まれています。 

 

各メニューの詳細は，6章を参照してください。 

[Help]メニュー 

 
 

 

 

[Help]メニューには，GX Configurator-STのキー操作，ソフ

トウェアバージョンを確認する機能が含まれています。 
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４ 操作手順 

4.1 GX Configurator-ST使用時の注意事項 

GX Configurator-ST使用時の注意事項について説明します。 

 

(1) パソコンのレジューム機能・サスペンド設定・省電力機能・スタンバイモードを

設定してMELSEC-STシステムと交信すると交信エラーが発生することがあります。 

そのためMELSEC-STシステムと交信する場合は，本機能の設定を行わないでくださ

い。 

 

4.2 編集モードの操作手順 

プロジェクトの新規作成，編集を行い，ヘッドユニットに書き込みます。 
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4.3 診断モードの操作手順 

エラー状態の確認と処置，または入出力データのモニタ／テスト，などを行います。 

 

(1) 診断モードの準備 

診断モードの操作を行うための準備を行います。 

診断モードの操作を行う前に，本操作を行ってください。 
 

 

 
(2) 診断モードの操作手順 

使用目的別に，参照項で説明する操作を行ってください。 

診断モードの操作を行う前に，本節(1)の操作を行ってください。 
 

使用目的 参照項 

MELSEC-STシステムをモニタしたい。 

エラーが発生したユニットを確認したい。 
10.1節 

エラー内容を確認したい。 10.2節 

オフセット・ゲイン値を設定したい。  9.5節 

入出力データを確認したい。 10.3節 

強制入出力テストを行いたい。 10.4節 

マスタ局との交信データをモニタしたい。 10.5節 

PROFIBUS-DPネットワークパラメータをモニタしたい。 10.6節 

ヘッドユニットをリセットしたい。 11.1節 

オンラインユニット交換を行いたい。 11.2節 
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５ インストール，アンインストール 

GX Configurator-STのインストール，アンインストール方法について説明します。 

 

5.1 インストール 

 

5.1.1 インストール手順 

GX Configurator-STのインストールは下記の手順で行ってください。 
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5.1.2 インストール 

GX Configurator-STのインストール方法を下記に示します。 

本項で説明に使用する場合は，Microsoft R Windows R XP Professional Operating 

Systemを使用しています。 

 

  

   

(1) インストールを行う前に，Windows R で動作させている他のアプリケーションを

すべて終了してください。 

(2) 下記のOSにインストールを行う場合は，Administrator（コンピュータ管理者）

の属性を持つユーザとしてログオンしてください。 

・Microsoft R Windows NT R Workstation Operating System Version 4.0 

・Microsoft R Windows R 2000 Professional Operating System 

・Microsoft R Windows R XP Professional Operating System 

・Microsoft R Windows R XP Home Edition Operating System 

(3) インストールを行うパソコンに，GX Configurator-STがインストールされてい

るか確認してください。 

す で に GX Configurator-ST が イ ン ス ト ー ル さ れ て い る 場 合 は ， GX 

Configurator-STをアンインストールし，パソコンを再起動してから本ソフト

ウェアをインストールしてください。 
 

 

(1) GX Configurator-STのインストール 

 

 1) パソコンの電源を投入後，Windows R を起動します。 

2) Windows R のエクスプローラを起動してディスクが挿入されて

いるドライブをクリックします。 

“SETUP”（ ）をダブルクリックします。 

Windows R のエクスプローラの表示は，[start]→ 

[All Programs]→[Accessories]→[Windows Explorer]を選択

します。 

↓ 

（次のページへ） 

 

 

 

 

 

 

 

 

 

 

 

5 
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（前ページより） 

↓ 

 

 

 

3) 左記のいずれかの画面が表示された場合，本項の“(参考)イン

ストール起動時にメッセージが表示された場合”内の，(a)の

指示に従って作業を行ってください。 

作業が終了したら，再度インストールを行ってください。 

左記画面が表示された場合，本項の“(参考)インストール起動

時にメッセージが表示された場合”内の，(b)の指示に従って

作業を行ってください。 

作業が終了したら，再度インストールを行ってください。 

↓  

4) 左記の画面が表示されますので，すべてのアプリケーションが

終了していることを確認して OK ボタンをクリックしてくだ

さい。 

アプリケーションが動作している場合は，動作しているアプリ

ケーションをすべて終了させてください。 

↓  

5) 左記の画面が表示されますので， Next ボタンをクリックして

ください。 

↓ 

（次ページへ） 
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（前ページより） 

↓ 

 

6) 名前と会社名を入力し， Next ボタンをクリックします。 

↓  

7) 登録された名前と会社名を確認します。正しければ Yes ボタ

ンをクリックします。 

変更する場合は， No ボタンをクリックし前画面に戻ります。

↓  

8) 製品のプロダクトID を入力し， Next ボタンをクリックしま

す。 

プロダクトID は，製品に同梱されている“ソフトウェア登録

証”に記載されています。 

↓ 

（次のページへ） 
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（前ページより） 

↓ 

 

9) インストール先フォルダを指定します。 

インストール先フォルダを指定したら Next ボタンをクリッ

クします。 

デフォルトは「C:\MELSEC \」です。変更する場合は Browse ボ

タンをクリックし，変更先のドライブ，フォルダを指定します。

↓  

10) 左記の画面が表示されるとインストールの完了です。 

 OK ボタンをクリックします。 

↓  

左記のメッセージが表示された場合は，Windows R を再起動さ

せる必要があります。 

↓ 

（完了） 
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GX Configurator-STをインストールすると次のようにアイコンが登録されます。 
 

 

備  考 

下記OSを使用時は，[Start]→[Programs]→[MELSOFT Application]にアイコンが登

録されます。 

・Microsoft R Windows R 95 Operating System 

・Microsoft R Windows R 98 Operating System 

・Microsoft R Windows R Millennium Edition Operating System 

・Microsoft R Windows NT R Workstation Operating System Version 4.0 

・Microsoft R Windows R 2000 Professional Operating System 
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(参考) インストール起動時にメッセージが表示された場合 

本製品のインストール開始時に，“本パッケージは動作可能な環境になっており

ません”というメッセージが表示され，インストールが正常に完了しない場合が

あります。 

このような場合，すべてのアプリケーションを終了し，(a)または(b)に示す作業

を行ってください。 

 

(a) dcom95.exeおよびaxdist.exeのインストール 

GX Configurator-STに添付のdcom95.exeおよびaxdist.exeを実行してくださ

い。 

exeファイル実行後パソコンを再起動し，GX Configurator-STのインストール

を行ってください。 

下記に各OSで実行するexeファイルを示します。 
 

O  S ファイル名 

Microsoft R Windows R 95 Operating System 

Microsoft R Windows R 98 Operating System 

dcom95.exe 

axdist.exe 

Microsoft R Windows NT R Workstation Operating System Version 4.0 axdist.exe 
 

（dcom95.exeおよびaxdist.exeは，本製品CD-ROM内の“Update”フォルダ内

にあります。） 

 

(b) EnvMELのインストール 

本製品CD-ROM内の“EnvMEL”フォルダ内にあるSetup.exeを実行してください。 

Setup.exeを実行後，GX Configurator-STのインストールを行ってください。 

 

＊：上記のexeファイルの実行後，再度製品のインストールを実行してください。 

このとき，本製品のインストールが正しく実施されない場合は，パソコンの

再起動を行ってください。 
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5.2 アンインストール 

ハードディスクからGX Configurator-STを削除する操作について説明します。 

本項で説明に使用する画面は，Windows R XP Professionalを使用しています。 

Windows R 2000 Professionalなどの画面とは多少異なりますが 備考 を参考にイン

ストールを実行してください。 
 

1) コントロールパネルの“Add or Remove Programs”をダブルク

リックします。コントロールパネルの表示は[start]→

[Control Panel]を選択します。 

 

 備  考  

下記のOS使用時は，コントロールパネルの“Add/Remove 

Programs”をダブルクリックします。コントロールパネルの表

示は[Start]→[Settings]→[Control Panel]を選択します。 

・Windows R 95 

・Windows R 98 

・Windows R Me 

・Windows NT R Workstation 4.0 

・Windows R 2000 Professional 

↓  

2) “Change or Remove Programs”を選択し，“GX Configurator-ST 

Version 1”を選択します。 

選択後， Change/Remove ボタンをクリックします。 

 

 備  考  

(a) 下記のOS使用時は，“Install/Uninstall”を選択し， 

“GX Configurator-ST Version 1”を選択します。 

選択後， Add/Remove ボタンをクリックします。 

・Windows R 95 

・Windows R 98 

・Windows R Me 

・Windows NT R Workstation 4.0 
 

(b) Windows R 2000 Professional使用時は，“Change or Remove 

Programs”を選択し，“GX Configurator-ST Version 1”

を選択します。 

選択後， Remove ボタンをクリックします。 

↓  

3) ファイル削除の確認をします。 

 Yes ボタンをクリックするとアンインストールを開始しま

す。 

 No ボタンをクリックするとアンインストールを中断します。

↓ 

（次のページへ） 
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（前ページより） 

↓ 

 

4) 左の画面が表示された場合は， No to All ボタンをクリック

してください。 

 Yes ボタン， Yes to All ボタンをクリックすると，Windows R

対応のMELSOFTソフトウェア群の共有ファイルが削除されます

ので，GX Configurator-STのみ削除の場合は No to All ボタ

ンをクリックしてください。 

↓  

5) 削除作業が終了したメッセージが表示されましたら OK ボタン

をクリックします。 

完了のメッセージが表示されたらアンインストール完了です。

↓ 

（完  了） 
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5.3 GX Configurator-STの起動 

GX Configurator-STをスタートメニューから起動する方法について説明します。 
  

1) [start]→[All Programs＊1]→[MELSOFT Application]へカーソ

ルを移動させます。 

 

＊1：下記OS使用時は，[Programs]と表示されます。 

・Windows R 95 

・Windows R 98 

・Windows R Me 

・Windows NT R Workstation 4.0 

・Windows R 2000 Professional 

↓  

2) [GX Configurator-ST]をクリックします。 

↓  

3) GX Configurator-STが起動します。 
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備  考 

GX Configurator-STは複数個起動して使用できます。 

複数のGX Configurator-STで別々のプロジェクトを開くことができるため，複数の

プロジェクトを同時に参照することができます。 

複数のGX Configurator-STから同一のプロジェクトを開くことはできません。 

 

複数個起動した場合には，起動した順番が2番目以降のGX Configurator-STには下記

の制約事項があります。 

① 診断モードを使用できません。 

[Mode]→[Diagnosis]メニュー（ ）をクリックできません。 

② 各種情報取得ができません。 

[Online]→[Get System]メニュー（ ）をクリックできません。 

③ パラメータ一括書込みができません。 

[Online]→[Parameter Block Write]メニューをクリックできません。 

④ パラメータ設定画面にてパラメータの読出し，書込み，および照合ができません。 

 Upload ， Download ， Verify ボタンをクリックできません。 

最初に起動したGX Configurator-STは，上記の制約事項が適用されないため上記の

操作を行うことができます。 

最初に起動したGX Configurator-STを終了しても，起動しているすべてのGX 

Configurator-STから上記の制約事項は解除されません。 

制約事項を解除するには，起動しているすべてのGX Configurator-STを終了してか

ら，GX Configurator-STを再起動してください。 
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5.4 GX Configurator-STの終了 

GX Configurator-STを終了する方法について説明します。 

 

(1) メニューによる終了方法 
 

 
[File]→[Exit]メニューをクリックします。 

GX Configurator-STが終了します。 

 

(2) Titlebarによる終了方法 
 

 
をクリックし，[Close]を選択します。 

またはTitlebar右端の をクリックします。 

 

  

   

(1) 印刷プレビューを表示している間は，GX Configurator-STを終了できません。

印刷プレビューを閉じてから，GX Configurator-STを終了してください。 

(2) GX Configurator-STを起動中は，パソコンを再起動または終了できません。 

GX Configurator-STを終了してから，パソコンを再起動または終了してくださ

い。 
 

 

備  考 

新規作成した場合，または変更して保存を行ってない場合，プロジェクトを保存す

るか確認のダイアログボックスが表示されます。 

保存しない場合は， No ボタンをクリックしてください。 

保存する場合は， Yes ボタンをクリックしてください。 

新規作成で保存する場合は，プロジェクトに名前を付けて保存します。 

詳細は7.4.2項を参照してください。 
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６ 画面構成と表示切換え 

GX Configurator-STの画面構成，各部の表示切換えについて説明します。 
 

(1) 画面構成 

GX Configurator-STの画面構成を下記に示します。 
 

Statusbar

Exits 
GX Configurator-ST

Screen maximize button

Screen minimize button

Dropdown menu

Titlebar

Menubar

Toolbar

Module Information 
List Window

 

 

名  称 内  容 

Titlebar 

開いているプロジェクトのファイル名を表示します。 

2つ以上のGX Configurator-STを起動した場合は，2番目以降に起動したGX Configurator-STに

は，ファイル名の前に“Edit Mode only”を表示します。 
 

 

 
GX Configurator-STの中の“Window”を最大化した場合は，その“Window”の名称を表示しま

す。 

 

 

Menubar 

Dropdown menu 

メニューをクリックすると“Dropdown menu”を開き，“Dropdown menu”の各項目をクリック

するとGX Configurator-STの各機能を実行します。 

詳細は，3.2節を参照してください。 

Toolbar 
ボタンをクリックしてGX Configurator-STの各機能を実行します。 

詳細は，本章(3)を参照してください。 

Screen minimize button クリックするとGX Configurator-STを最小化します。 

Screen maxmize button クリックするとGX Configurator-STを最大化します。 

Exits GX Configurator-ST クリックするとGX Configurator-STを終了します。 

 

 

 

 

 

 

 

 

 

 

 

 

 6 
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名  称 内  容 

Module Information List 

プロジェクトに登録されているユニットを一覧表示します。 

ユニットをダブルクリックするとパラメータを設定できます。 

ユニットの上で右クリックするとメニューが表示され，選択すると各機能を実行できます。 

Window “Parameter Setting”画面，“Result Verify”画面などを表示します。 

Statusbar 

“Dropdown menu”の各項目にマウスを重ねたときに，その項目の説明を表示します。 

また，下記の情報を表示します。 

・現在のGX Configurator-STのモード 

・診断モード時には，接続したヘッドユニットの局番 
 

 
 

 

(2) 表示切換えおよびウィンドウの整列操作 

下記の操作により，各ツールバーの表示／非表示を切り換えたり，ウィンドウを

整列することができます。 
 

操  作 内  容 

[View]→[Module Information List]

“Module Information List”画面の表示／非表示を

切り換えます。 

編集モード時のみ，本操作を行えます。 

[View]→[Initialize Module 

Information List View 

Position] 

“Module Information List”画面の表示位置を初期

状態に戻します。 

編集モード時のみ，本操作を行えます。 

[View]→[System Monitor] 

“System Monitor”画面の表示／非表示を切り換え

ます。 

診断モード時のみ，本操作を行えます。 

[View]→[Toolbar] “Toolbar”の表示／非表示を切り換えます。 

[View]→[Statusbar] “Statusbar”の表示／非表示を切り換えます。 

[Window]→[Cascade] 
GX Configurator-STの中に開いている，複数の

“Window”を重ねて表示します。 

[Window]→[Tile Vertically] 複数の“Window”を左右に並べて表示します。 

[Window]→[Tile Horizontally] 複数の“Window”を上下に並べて表示します。 

[Window]→[Arrange Icons] “Window”を最小化したアイコンを整列します。 

[Window]→[Close All Windows] 

すべての“Window”を閉じます。 

編集中の“Window”がある場合は，確認のメッセー

ジを表示します。 
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(3) Toolbarの詳細 

Toolbarに含まれるボタンについて説明します。 

 

 

 

ボタン 名  称 内  容 参照項 

 New 新規にプロジェクトを作成します。 7.1節 

 Open 既存のプロジェクトを開きます。 7.2節 

 Save 開いているプロジェクトを，既存のプロジェクトに上書き保存します。 7.4.1項 

 Print 
開いているプロジェクトの，ユニット構成，ユニット情報の一覧，および各ユニッ

トの詳細情報を印刷します。 
7.6節 

 Undo 実行した操作を元に戻します。 8.5節 

 Redo “Undo”の処理を行う前の状態に戻します。 8.6節 

 Add プロジェクトにスライスユニットを追加します。 8.1節 

 Delete プロジェクトからスライスユニットを削除します。 8.2節 

 All Delete プロジェクトからすべてのスライスユニットを削除します。 8.3節 

 
Parameter 

Setting 

インテリジェント機能ユニットのパラメータを設定します。 
8.8節 

 Edit 編集モードに切り換えます。 － 

 Diagnosis 診断モードに切り換えます。 － 

 Get System 
ヘッドユニットからシステム構成および各ユニットのパラメータを読み出しま

す。 
9.2節 

 About GX Configurator-STのソフトウェアバージョンを表示します。 － 
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７ プロジェクトの作成 

GX Configurator-STのプロジェクトを作成する方法について説明します。 

 

7.1 新規プロジェクトの作成 

 

 
新規にプロジェクトを作成します。 

 

 
 

[File]→[New]メニュー（ ）をクリック，またはキーボードの Ctrl ＋ N キー

を押すと，“Module Information List”画面に新規のプロジェクトを表示します。 

 

7.2 既存プロジェクトを開く 

 

 
保存したプロジェクトを読み出します。 

 

 
 

(1) [File]→[Open]メニュー（ ）をクリック，またはキーボードの Ctrl ＋ 

 O キーを押します。 

(2) 開いた画面で開くプロジェクトを選択し， Open ボタンをクリックすると，

“Module Information List”画面に開いたプロジェクトを表示します。 

 

 
 

 

 

 
 

項  目 内  容 

Lock in 開くプロジェクトを保管しているディレクトリを選択します。 

File name 開くプロジェクトのファイル名を設定します。 
 
  Open ボタン 
 

“File name”に指定したプロジェクトを開きます。 

 
  Cancel ボタン 
 

プロジェクトを開かずに，本画面を閉じます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 7 
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7.3 プロジェクトを閉じる 

 

 
現在開いているプロジェクトを閉じます。 

 

 
 

(1) [File]→[Close]メニューをクリックします。 

(2) 新規のプロジェクト，または変更を加えてから保存していないプロジェクト

を閉じる場合は，プロジェクトの保存を確認する下記の画面が表示されます。 
 

 

 
保存しない場合は， No ボタンをクリックします。 

保存する場合は， Yes ボタンをクリックします。 

保存するときにプロジェクトが新規作成の場合は，プロジェクトに名前を付

けて保存します。 

詳細は，7.4.2項を参照してください。 

(3) 保存したプロジェクトを開いてから一切変更していない場合は，プロジェク

トを閉じることを確認する下記の画面が表示されます。 
 

 

 
 Yes ボタンをクリックすると，プロジェクトを閉じます。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 7 
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7.4 プロジェクトの保存 

7.4.1 上書き保存 

 

 
開いているプロジェクトを，既存のプロジェクトに上書き保存します。 

 

 
 

[File]→[Save]メニュー（ ）をクリック，またはキーボードの Ctrl ＋ S  

キーを押します。 

開いているプロジェクトが，新規のプロジェクトの場合は，名前を付けて保存し

ます。 

詳細は，7.4.2項を参照してください。 

 

7.4.2 名前を付けて保存 

 

 
開いているプロジェクトに名前を付けて保存します。 

 

 
 

(1) [File]→[Save As]メニューをクリックします。 

(2) 開いた画面で保存先のディレクトリを選択してファイル名を設定し， Save ボ

タンをクリックします。 

 

 
 

 

 
 

 

項  目 内  容 

Save in プロジェクトを保存するディレクトリを選択します。 

File name 保存するプロジェクトのファイル名を設定します。 
 
  Save ボタン 
 

“File name”に指定したファイル名で，プロジェクトを保存します。 

 
  Cancel ボタン 
 

プロジェクトを保存せずに，本画面を閉じます。 
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7.5 プロジェクトの照合 

2つのプロジェクト間で照合を行い，パラメータの一致／不一致を確認します。 

 

照合には下記の2種類の照合があります。 

(1) n：nの照合 

開いているプロジェクトと保存したプロジェクトとで，同一No.同士のすべてのユ

ニットを照合します。 

照合操作の詳細は，7.5.1項を参照してください。 

照合結果の詳細は，7.5.2項を参照してください。 

 

(2) 1：nの照合 

2つのプロジェクトの内，一方のプロジェクトから1つのユニットを選択し，もう

一方のプロジェクトから複数のユニットを選択し，前者の1つのユニットと後者の

複数のユニットとを照合します。 

照合操作の詳細は，7.5.3項を参照してください。 

照合結果の詳細は，7.5.2項を参照してください。 

 

7.5.1 n：nの照合 

 

 
開いているプロジェクトと保存したプロジェクトとで，同一No.同士のすべてのユ

ニットを照合します。 

 

 
 

(1) [File]→[Verify]メニューをクリックすると，“Verify”画面が表示されま

す。 

(2) <<Verify All Modules>>タブを開きます。 

(3)  Browse ボタンをクリックして，照合相手のプロジェクトを指定します。 

(4)  Execute ボタンをクリックすると，照合を行い，本画面を閉じ，結果を表示

します。 

詳細は，7.5.2項を参照してください。 
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項  目 内  容 

Verification Destination File 照合相手のプロジェクトを指定します。 

 Drive/Path 

 
  Browse ボタンにより指定した照合相手のプロジェクトの，保存されているドライブ

とディレクトリを表示します。 

 File Name 

 
  Browse ボタンにより指定した照合相手のプロジェクトの，ファイル名を表示しま

す。 

 
 
  Browse ボタン 
 

プロジェクトを指定します。 

操作は既存のプロジェクトを開く操作と同じです。 

詳細は，7.2節を参照してください。 
 
  Close ボタン 
 

プロジェクトを照合せずに，本画面を閉じます。 

<<Verify All Modules>>タブ n：nの照合を行います。 

 
 
  Execute ボタン＊1 
 

プロジェクトの照合を行い，本画面を閉じ，照合結果を表示します。 

照合結果の詳細は，7.5.2項を参照してください。 

 Verification Source＊2 開いているプロジェクトの，全ユニットを一覧表示します。 

 Verification Destination＊2 照合相手のプロジェクトの，全ユニットを一覧表示します。 
 
＊1：開いているプロジェクトと照合相手のプロジェクトとでシステム構成が違う場合は， Execute ボタンをクリックでき

ません。 

＊2：パラメータを持たないユニットは照合する必要がないため，灰色で表示して照合を行いません。 

パラメータを編集できないユニットであっても，パラメータを読み出すことができるユニットについては，照合を行

うことができます。 
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7.5.2 照合結果 

 

 
n：nの照合または1：nの照合により表示された，照合結果を確認します。 

 
 

 
(1) 照合結果が不一致だったパラメータを持つユニットは，照合ユニット一覧に

赤色で表示されます。 

照合結果が不一致だったパラメータを表示する場合は，赤色で表示されたユ

ニットをクリックします。 

(2) パラメータを変更する場合は，変更するユニットをダブルクリック，または

変更するユニットを選択して Parameter Setting ボタンをクリックします。 

(3) 本画面を閉じる場合は， ボタンをクリックします。 
 

 
 

 

 
 

 

項  目 内  容 

Verification Source File 

照合元のプロジェクトのファイル名を表示します。 

照合元のプロジェクトを新規作成してから一度も保存していない場合は，“Untitled”

を表示します。 

Verification Destination File 照合相手のプロジェクトのファイル名を表示します。 

照合ユニット一覧 

照合を行ったユニットの一覧を表示します。 

赤色で表示された場合は，照合結果が不一致だったことを示します。 

ダブルクリックすると，ダブルクリックしたユニットのパラメータを変更できます。

詳細は，8.8節を参照してください。 

 No.(Src) 照合元のユニットのNo.を表示します。 

 Module Name(Src) 照合元のユニットのユニット形名を表示します。 

 No.(Dst) 照合相手のユニットのNo.を表示します。 

 Module Name(Dst) 照合相手のユニットのユニット形名を表示します。 

 Mismatch Items 

照合結果が不一致となった項目の数を表示します。 

“----”が表示された場合は，“Module Name(Src)”と“Module Name(Dst)”とが違

うユニットであることを示します。 
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項  目 内  容 

 
  Parameter Setting ボタン 
 

照合ユニット一覧で選択したユニットの，パラメータを変更します。 

詳細は，8.8節を参照してください。 

変更対象のプロジェクトは開いているプロジェクトです。 

不一致パラメータ一覧 
照合ユニット一覧で選択したユニットの，照合が不一致だったパラメータを表示しま

す。 

 No. 通し番号を表示します。 

 Item パラメータの名称を表示します。 

 Verify Source Setting Value 照合元のユニットの，パラメータを表示します。 

 
Verify Destination Setting 

Value 
照合相手のユニットの，パラメータを表示します。 

 

 

7.5.3 1：nの照合 

 

 
2つのプロジェクトの内，一方のプロジェクトから1つのユニットを選択し，もう

一方のプロジェクトから複数のユニットを選択し，前者の1つのユニットと後者の

複数のユニットとを照合します。 

 

 
 

(1) [File]→[Verify]メニューをクリックすると，“Verify”画面が表示されま

す。 

(2) <<Verify Selected Modules>>タブを開きます 

(3)  Browse ボタンで，照合相手のプロジェクトを指定します。 

(4) “Select Verification Source File”のラジオボタンで，照合元のユニット

を含むプロジェクトを選択します。 

(5)  Add ボタンで，照合元のユニットを選択します。 

(6)  Add ／ Delete ボタンで，照合相手のユニットを選択します。 

(7)  Execute ボタンをクリックすると，照合を行い，本画面を閉じ，結果を表示

します。 

詳細は，7.5.2項を参照してください。 
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Select Verification Source File

 

 

 
 

項  目 内  容 

Verification Destination File 

照合相手のプロジェクトを指定します。 

操作は，n：nの照合を行う場合と同じです。 

詳細は，7.5.1項を参照してください。 
 
  Close ボタン 
 

プロジェクトを照合せずに，本画面を閉じます。 

<<Verify Selected Modules>>タブ 1：nの照合を行います。 

 
Select Verification Source 

File 

照合元のユニットを含むプロジェクトを選択します。 

・“Opened File”を選択すると，照合元のユニットを開いているプロジェクトから選

択します。 

・“Verification Target File”を選択すると，照合元のユニットを“Verification 

Destination File”に指定したプロジェクトから選択します。 

 
 
  Execute ボタン 
 

照合を行い，本画面を閉じ，照合結果を表示します。 

照合結果の詳細は，7.5.2項を参照してください。 

 Opened File＊1 開いているプロジェクトの，全ユニットを一覧表示します。 

  
 
  Add ボタン 
 

選択したユニットを“Verification Source Module”または“Verification Destination 

Module”へ追加します。 

追加先は“Select Verification Source File”の選択によって変わります。 

・“Opened File”の場合は，“Verification Source Module”へ追加します。 

・“Verification Target File”の場合は，“Verification Destination Module”へ

追加します。 
 
＊1：パラメータを持たないユニットは照合する必要がないため，灰色で表示して照合を行いません。 

パラメータを編集できないユニットであっても，パラメータを読み出すことができるユニットについては，照合を行

うことができます。 
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項  目 内  容 

Verify Selected Modules － 

 Verification Target File＊1 照合相手のプロジェクトの，全ユニットを一覧表示します。 

  
 
  Add ボタン 
 

選択したユニットを“Verification Source Module”または“Verification Destination 

Module”へ追加します。 

追加先は“Select Verification Source File”の選択によって変わります。 

・“Opened File”の場合は，“Verification Destination Module”へ追加します。

・“Verification Target File”の場合は，“Verification Source Module”へ追加

します。 

 Verification Source Module 
照合元として選択されたユニットを表示します。 

本項目に選択できるユニットは１つだけです。 

 
Verification Destination 

Module 
照合するユニットを表示します。 

  
 
  Delete ボタン 
 

選択したユニットを削除します。 

 
＊1：パラメータを持たないユニットは照合する必要がないため，灰色で表示して照合を行いません。 

パラメータを編集できないユニットであっても，パラメータを読み出すことができるユニットについては，照合を行

うことができます。 
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7.6 プロジェクトデータの印刷 

 

 
開いているプロジェクトの，ユニット構成，ユニット情報の一覧，および各ユニッ

トの詳細情報を印刷します。 

 

 
 

(1) [File]→[Print]メニュー（ ）をクリック，またはキーボードの Ctrl ＋ 

 P キーを押します。 

(2) 開いた画面で印刷内容（Module Configuration，Module Information Listま

た は Individual Module Information （ Module Detail Information ，

Parameter））の選択などの設定を行います。 

(3)  Print ボタンをクリックして，印刷します。 

印刷結果は，7.6.4項を参照してください。 

 

 
 

 

 

 
 

項  目 内  容 

Module Configuration チェックすると，ユニット構成を印刷するように設定します。 

Module Turning Position 
ユニット構成の印刷時に，ユニットを横に並べる数を設定します。 

“Module Configuration”にチェックしている時のみ，本項目を操作可能です。 

Module Information List チェックすると，ユニット情報の一覧を印刷するように設定します。 

Individual Module Information 

(Module Detail Information, 

Parameter) 

チェックすると，“Print Range”で指定したユニットの詳細情報を印刷するように設

定します。 
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項  目 内  容 

Alignment ユニット名の印刷方向を選択します。 

 
Print the module name by 

columnar writing 

ユニット名を縦書きで印刷します。 

 

 
Print the module name by 

horizontal writing 

ユニット名を横書きで印刷します。 

 

Print Range 

個々のユニットの詳細情報を印刷する時に，印刷するユニットを設定します。 

“Individual Module Information”にチェックしている時のみ，本項目を操作可能で

す。 

 All Modules すべてのユニットの，詳細情報を印刷するように設定します。 

 Selected Modules 
“The module to print”に表示されたユニットの，詳細情報を印刷するように設定し

ます。 

 
 
  -> ボタン 
 

左側の一覧で選択しているユニットを，印刷するユニットとして，“The module to 

print”の最後に追加します。 

 
 
  <- ボタン 
 

“The module to print”で選択しているユニットを，印刷するユニットから除外し，

“The module to print”から削除します。 

 
  Printer Setup ボタン 
 

プリンタの設定を行います。 

詳細は，7.6.1項を参照してください。 

 
  Page Setup ボタン 
 

ページ設定を行います。 

詳細は，7.6.2項を参照してください。 
 
  Print ボタン 
 

印刷します。 

 
  Print Preview ボタン 
 

本画面を閉じて，印刷時のイメージを表示します。 

詳細は，7.6.3項を参照してください。 
 
  Close ボタン 
 

印刷せずに，本画面を閉じます。 
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7.6.1 プリンタの設定 

 

 
印刷をするプリンタの選択，用紙サイズ，印刷の向きなどの設定をします。 

 

 
 

(1) “Print”画面にて Printer Setup ボタンをクリックすると，本画面が表示

されます。 

(2) 印刷をするプリンタの選択，用紙サイズ，印刷の向きなどの設定をします。 

(3) 本画面を閉じる場合は， OK ボタンをクリックします。 

 

 
 

 

 

 
 

項  目 内  容 

Printer 印刷をするプリンタを選択します。 

 
 
  Propaties ボタン 
 

クリックすると，プリンタのプロパティダイアログボックスを表示します。 

プリンタのプロパティでは，プリンタの基本設定を行います。 

Paper 
印刷する用紙サイズとプリンタの給紙方法を設定します。 

設定範囲は，各プリンタにより異なります。 

Orientation － 

 Portrait 用紙に対して縦に印刷します。 

 Landscape 用紙に対して横に印刷します。 

 
  Network ボタン 
 

共有された，ネットワークフォルダに接続するときにクリックします。 

本項目は下記OSの場合のみ，本項目は表示されます。 

・Microsoft R Windows R 2000 Professional Operating System 

・Microsoft R Windows R XP Professional Operating System 

・Microsoft R Windows R XP Home Edition Operating System 
 
  OK ボタン 
 

設定が終了したらクリックします。 

 
  Cancel ボタン 
 

設定をキャンセルして，本画面を閉じます。 

 

  

   

プリンタのプロパティ設定については，プリンタのメーカ，機種により異なるため，

ご使用のプリンタの取扱説明書をよくお読みください。 
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7.6.2 ページ設定 

 

 
用紙，ページ番号，ヘッダなどのページ設定をします。 

 

 
 

(1) “Print”画面にて Page Setup ボタンをクリックすると，本画面が表示され

ます。 

(2) 用紙，ページ番号，ヘッダなどのページ設定をします。 

(3) 本画面を閉じる場合は， OK ボタンをクリックします。 

 

 
 

 

 

 
 

項  目 内  容 

Paper 用紙サイズ，給紙方法を設定します。 

Print Orientation 用紙に印刷する向きを設定します。 

Margins 用紙の余白を設定します。 

Page No. Setting ページ番号の設定を行います。 

 Page No. Format 

ページ番号の書式を選択します。 

・“-**-”はページごとに初期値から開始する番号を付けます。 

・“-**/**-”はページ番号と総ページ数を付けます。 

・ページ番号を付けない場合“なし”を設定します。 

 No. Position ページ番号の位置を設定します。 

 Initial Value 1枚目に付けるページ番号を設定します。 
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項  目 内  容 

Common Header Setting／ 

Common Footer Setting 

チェックボックスに 印をつけると，各ページにヘッダーを付けます。 

  Edit Header ボタンをクリックすると，下記の“Edit Header”ダイアログボックス

を開きます。 
 

 

 
  Edit Footer ボタンをクリックすると，“Edit Header”ダイアログボックスと同様

の“Edit Footer”ダイアログボックスを開きます。 

ヘッダー（フッター）の編集範囲は，半角64文字×7行の文字のみです。 

線画の編集や文字の装飾は行えません。 
 
  OK ボタン 
 

設定が終了したらクリックします。 

 
  Cancel ボタン 
 

設定をキャンセルして，本画面を閉じます。 

 
  Printer Setup ボタン 
 

クリックすると，プリンタ設定画面を表示します。 

印刷するプリンタを選択して， OK ボタンをクリックします。 
 

 

 
 

  

   

・ 印刷の文字が小さい場合は，余白設定の値を小さくしてください。 

・ 印刷プレビュー画面で，マウスポインタが のときにクリックすると，ズーム

インします。マウスポインタが のときにクリックすると，標準表示になりま

す。 
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7.6.3 印刷時のイメージ表示 

 

 
ページ全体を印刷時のイメージで表示します。 

 

 
 

(1) “Print”画面にて Print Preview ボタンをクリックすると，ページ全体を

印刷時のイメージで表示します。 

(2) “Print”画面に戻る場合は， Print ボタンをクリックします。 

(3) イメージ表示を終了する場合は， Close ボタンをクリックします。 

 

 
 

 

 

 
 

項  目 内  容 

 
  Print ボタン 
 

イメージの表示を終了して，“Print”画面を表示します。 

“Print”画面の詳細は，7.6節を参照してください。 

 
  Zoom In ボタン 
 

クリックすると拡大表示します。 

表示は3段階で切り換えられます。 
 
  Zoom Out ボタン 
 

クリックすると縮小表示します。 

 
  Close ボタン 
 

イメージの表示を終了します。 

 

  

   

印刷プレビュー画面で，マウスポインタが のときにクリックすると，ズームイン

します。マウスポインタが のときにクリックすると，標準表示になります。 
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7.6.4 印刷例 

印刷例を示します。 

 

(1) Module Configuration 
 

(a) 縦書き印刷(Print the module name by columnar writing設定時) 
 

 

 

(b) 横書き印刷(Print the module name by horizontal writing設定時) 
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(2) Module Information List 
 

 

 

(3) Individual Module Information 
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メ モ 
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８ プロジェクトの編集 

GX Configurator-STのプロジェクトを編集する方法について説明します。 

 

  

   

必ずプロジェクトに電源分配ユニットを加えてください。 
 

 

 

8.1 ユニットの追加 

 

 
プロジェクトにスライスユニットを追加します。 

 

 
 

(1) 下記の操作の内いずれかを実行すると，“Add Module”画面が表示されます。 

・ [Edit]→[Add]メニュー（ ）をクリックします。 

・ キーボードの Ctrl ＋ Insert キーを押します。 

・ “Module Information List”画面の一覧上でマウスを右クリックし，メ

ニューから[Add]をクリックします。 

(2) “Add Module”画面で，ユニットを追加する位置と形名を設定し， Add ボタ

ンをクリックします。 

(3) “Add Module”画面を閉じる場合は， Close ボタンをクリックします。 

 

  

   

“Module Information List”画面が表示された状態で操作を行ってください。 

“Module Information List”画面は，[View]→[Module Information List]メニュー

を選択すると表示されます。 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 8 

 

 

 

 

 



 

 

 

8 - 2                                         8 - 2 

８ プロジェクトの編集 
MELSOFT

 

 
 

 

 

 
 

項  目 内  容 

Insert Position スライスユニットを挿入する位置を設定します。 

 Last Position 

挿入する位置を最後尾に設定します。 

例：最後尾にユニットを追加した場合 

 

 

 No. 

ラジオボタンの“No.”を選択して，挿入する位置を“No.”で指定します。 

例：No.3にユニット（ST1Y16-TPE3）を追加した場合 

 
Select Module 追加するスライスユニットの形名を，プルダウンメニューで選択します。 

 Input/Output Module プルダウンメニューに入出力ユニットを表示し，選択できる状態にします。 

 Intelligent Module 
プルダウンメニューにインテリジェント機能ユニットを表示し，選択できる状態にし

ます。 

 Power Distribution Module プルダウンメニューに電源分配ユニットを表示し，選択できる状態にします。 
 
  Add ボタン＊1 
 

プロジェクトにスライスユニットを追加します。 

 
  Close ボタン 
 

スライスユニットを追加せずに，本画面を閉じます。 

 
＊1：ヘッドユニットの最大入出力点数設定を超えてスライスユニットを追加できません。 

最大入出力点数設定の設定は，8.9節を参照してください。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 8 
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8.2 ユニットの削除 

 

 
プロジェクトから選択したスライスユニットを削除します。 

 

 
 

(1) “Module Information List”画面で，削除するユニットを選択します。 

(2) 下記の操作の内，いずれかを実行します。 

・ [Edit]→[Delete]メニュー（ ）をクリックします。 

・ キーボードの Ctrl ＋ Delete キーを押します。 

・ “Module Information List”画面の削除するユニット上でマウスを右ク

リックし，メニューから[Delete]をクリックします。 

(3) 開いた画面で，削除するスライスユニットを確認して， Yes ボタンをクリッ

クすると，ユニットを削除します。 

削除したユニットよりNo.が大きいユニットは，No.を1つずつ減らします。 

 

8.3 ユニットをすべて削除 

 

 
プロジェクトからすべてのスライスユニットを削除します。 

 

 
 

(1) 下記の操作の内，いずれかを実行します。 

・ [Edit]→[All Delete]メニュー（ ）をクリックします。 

・ キーボードの Shift ＋ Delete キーを押します。 

・ “Module Information List”画面の一覧上でマウスを右クリックし，メ

ニューから[All Delete]をクリックします。 

(2) 開いた画面で， Yes ボタンをクリックします。 

 

  

   

“Module Information List”画面が表示された状態で操作を行ってください。

“Module Information List”画面は，[View]→[Module Information List]メニュー

を選択すると表示されます。 
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8.4 ユニット情報のコピー 

 

 
保存したプロジェクトから開いているプロジェクトへ，スライスユニットをコ

ピーします。 

このとき，コピーしたスライスユニットにはパラメータもコピーされます。 

 

 
 

(1) [File]→[Copy]メニューをクリックします。 

(2)  Browse ボタンで，コピー元のプロジェクトを指定します。 

(3) コピーするスライスユニットを選択し，“Insert Position”で挿入する位置

を設定して， Add ボタンをクリックします。 

(4) 本画面を閉じる場合は， Close ボタンをクリックします。 
 

  

   

“Module Information List”画面が表示された状態で操作を行ってください。 

“Module Information List”画面は，[View]→[Module Information List]メニュー

を選択すると表示されます。 
 

 

 
 

 

 

 
 

項  目 内  容 

Copy Source File コピー元のプロジェクトを指定します。 

 Drive/Path プロジェクトのドライブとディレクトリを表示します。 

 File Name プロジェクトのファイル名を表示します。 

 
 
  Browse ボタン 
 

プロジェクトを指定します。 

操作は既存のプロジェクトを開く操作と同じです。 

詳細は，7.2節を参照してください。 

プロジェクトを指定すると，“コピー元プロジェクトのユニット一覧”にコピー元プ

ロジェクトのユニットを一覧表示します。 
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項  目 内  容 

Insert Position スライスユニットを開いているプロジェクトへ挿入する位置の設定を行います。 

 Last Position 挿入する位置を最後尾に設定します。 

 No. ラジオボタンの“No.”を選択して，挿入する位置を“No.”で指定します。 

 
  Add ボタン 
 

“コピー元プロジェクトのユニット一覧”で選択したスライスユニットをコピーしま

す。 

スライスユニットを選択していない場合は，コピーしません。 
 
  Close ボタン 
 

本画面を閉じます。 

コピー元プロジェクトのユニット

一覧 
コピーするスライスユニットを選択します。 

 

 

8.5 操作を元に戻す 

 

 
下記操作を実行する前の状態に戻します。 

・ ユニットの追加 

・ ユニットの削除 

・ ユニットをすべて削除 

・ ユニット情報のコピー 

・ 各種情報取得 

 

 
 

下記の操作の内，いずれかを実行すると，1回分だけ実行する前の状態に戻します。 

・ [Edit]→[Undo]メニュー（ ）をクリックします。 

・ キーボードの Ctrl ＋ Z キーを押します。 

・ “Module Information List”画面の一覧上でマウスを右クリックし，メニュー

から[Undo]をクリックします。 

操作を繰り返すことで，最大10回分まで実行する前の状態に戻します。 

 

  

   

・ “Module Information List”画面が表示された状態で操作を行ってください。

“Module Information List”画面は，[View]→[Module Information List]メ

ニューを選択すると表示されます。 

・ プロジェクトを閉じるときに，操作履歴を消去します。 

プロジェクトを閉じると，閉じる前に行った操作を元に戻すことができなくな

ります。 
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8.6 操作のやり直し 

 

 
8.5節の“操作を元に戻す”の処理を行う前の状態に戻します。 

 

 
 

下記の操作の内，いずれかを実行します。 

・ [Edit]→[Redo]メニュー（ ）をクリックします。 

・ キーボードの Ctrl ＋ Y キーを押します。 

・ “Module Information List”画面の一覧上でマウスを右クリックし，メニュー

から[Redo]をクリックします。 

 

  

   

“Module Information List”画面が表示された状態で操作を行ってください。 

“Module Information List”画面は，[View]→[Module Information List]メニュー

を選択すると表示されます。 
 

 

 

8.7 ユニットの並び替え 

 

 
プロジェクトのスライスユニットを並び替えます。 

 

  

   

ヘッドユニットは並び替えできません。 
 

 

 
 

(1) 下記の操作の内，いずれかを実行します。 

・ [Edit]→[Rearrange]メニューをクリックします。 

・ “Module Information List”画面の一覧上でマウスを右クリックし，メ

ニューから[Rearrange]をクリックします。 

(2) 開いた画面で，一覧表示されているスライスユニットから移動するスライス

ユニットを選択し， Up / Down ボタンを使って移動します。 

(3) 本画面を閉じる場合は， OK ボタンをクリックします。 

 

  

   

“Module Information List”画面が表示された状態で操作を行ってください。 

“Module Information List”画面は，[View]→[Module Information List]メニュー

を選択すると表示されます。 
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項  目 内  容 

After Rearr. 並び替えた後のスライスユニットのNo.を表示します。 

Current No. 並び替える前のスライスユニットのNo.を表示します。 

Module Name 並び替えた後のスライスユニットの製品形名を表示します。 

 
  Up ボタン 
 

選択しているスライスユニットと一行上のスライスユニットとを，入れ換えます。 

選択しているスライスユニットが一番上のスライスユニットの場合は，入れ換えを行

いません。 

 
  Down ボタン 
 

選択しているスライスユニットと一行下のスライスユニットとを，入れ換えます。 

選択しているスライスユニットが一番下のスライスユニットの場合は，入れ換えを行

いません。 
 
  OK ボタン 
 

並び替えを有効にして，本画面を閉じます。 

 
  Cancel ボタン 
 

並び替えをキャンセルして，本画面を閉じます。 
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8.8 パラメータ設定 

ユニットのパラメータについては，下表の使用目的ごとに参照先の操作を行います。 

参照先の操作は，“Parameter Setting”画面にて行います。 

“Parameter Setting”画面の表示操作は，8.8.1項を参照してください。 
 

使用目的 参照項 

パラメータを設定したい。 8.8.2項 

パラメータを読み出したい。 

パラメータを書き込みたい。 

編集中のパラメータとユニットのパラメータとを照合したい。 

8.8.3項 

編集中のパラメータをエラーチェックして，パラメータのエラーを確認したい。 8.8.4項 

 

 

8.8.1 “Parameter Setting”画面の表示操作 

 

 
 

“Parameter Setting”画面の表示操作は，下記(1)～(3)の場合ごとに操作があり

ます。 

 

(1) 編集モードの場合 

(a) “Module Information List”画面が表示されていない場合は，[View]→

[Module Information List]メニューを選択して，“Module Information 

List”画面を表示させます。 

(b) “Module Information List”画面でパラメータの設定を行うユニットを

選択します。 

(c) 下記の操作の内いずれかを実行すると，“Parameter Setting”画面が表

示されます。 

・ [Edit]→[Parameter Setting]メニュー（ ）をクリックします。 

・ キーボードの F9 キーを押します。 

・ “Module Information List”画面でパラメータ設定するユニット上で

マウスを右クリックし，メニューから[Parameter Setting]をクリック

します。 

・ “Module Information List”画面でパラメータ設定するユニット上で

マウスをダブルクリックします。 
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(2) 診断モードの場合 

(a) “System Monitor”画面が表示されていない場合は，[View]→ 

[System Monitor]メニューを選択して，“System Monitor”画面を表示

させます。 

(b) “System Monitor”画面でパラメータの設定を行うユニットを選択しま

す。 

(c) 下記の操作の内いずれかを実行すると，“Parameter Setting”画面が表

示されます。 

・ [Edit]→[Parameter Setting]メニュー（ ）をクリックします。 

・ キーボードの F9 キーを押します。 

・ “System Monitor”画面でパラメータ設定するユニット上でマウスを

右クリックし，メニューから[Parameter Setting]をクリックします。 

・ “System Monitor”画面でパラメータ設定するユニットを選択し， 

 Parameter Setting ボタンをクリックします。 

 

(3) プロジェクトの照合の後に“Result Verify”画面を開いている場合 

下記の操作の内いずれかを実行すると，“Parameter Setting”画面が表示さ

れます。 

・ “Result Verify”画面でパラメータ設定するユニットの上でマウスをダ

ブルクリックします。 

・ “Result Verify”画面でパラメータ設定するユニットを選択し， 

 Parameter Setting ボタンをクリックします。 

 

 

8.8.2 パラメータを設定 

 

 
インテリジェント機能ユニットのパラメータを設定します。 

 

 
 

(1) 同一のパラメータを複数のチャンネルで持つユニットの場合は，パラメータ

を設定するチャンネルを“Channel”で選択します。 

(2) “パラメータ一覧”でパラメータを設定します。 

(3)  OK ボタンをクリックすると，本画面を閉じます。 

 



 

 

 

8 - 10                                         8 - 10 

８ プロジェクトの編集 
MELSOFT

 

 
 

 

 

 
 

項  目 内  容 

Module Information 
対象のインテリジェント機能ユニットの情報（先頭スライスNo.，ユニット形名，ラベ

ル名，ベースユニット形名）を表示します。 
 
  OK ボタン 
 

設定を有効にして，本画面を閉じます。 

 
  Cancel ボタン 
 

設定をキャンセルして，本画面を閉じます。 

Channel 

パラメータ一覧に表示するパラメータのチャンネルを指定します。 

同一のパラメータを複数のチャンネルで持つインテリジェント機能ユニットの場合の

み，本項目が表示され，操作できます。 

 
  Default ボタン 
 

“パラメータ一覧”のパラメータを初期値に戻します。 

パラメータを変更できるユニットの場合のみ，本項目を表示して操作可能です。 

パラメータ一覧 

インテリジェント機能ユニットが持つパラメータが一覧表示され，編集できます。 

インテリジェント機能ユニットが持つパラメータの種類と用途については，各インテ

リジェント機能ユニットのマニュアルを参照してください。 

 Item パラメータの名前を表示します。 

 Setting Value 
パラメータを編集します。 

編集できないパラメータの場合は，灰色に表示して編集を行えません。 
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8.8.3 パラメータを読出し／書込み，または編集中のパラメータとユニットのパラメータとを照合 

 

 
パラメータを読出し／書込み，または編集中のパラメータとユニットのパラメー

タとを照合します。 

 

 
 

(1) 同一のパラメータを複数のチャンネルで持つユニットの場合は，読出し，書

込み，または照合を行うパラメータのチャンネルを“Channel”で選択します。 

(2) 読出し，書込み，または照合を行うパラメータを選択します。 

選択は“パラメータ一覧”の“Select”のチェックボックスにチェックする

ことで行います。 

(3) “Target Memory”で，読出し，書込み，および照合の対象とするメモリを選

択します。 

(4) 読出しを行う場合は， Upload ボタンをクリックすると，読出しを行います。 

(5) 書込みを行う場合は， Download ボタンをクリックすると，書込みを行いま

す。 

(6) 照合を行う場合は， Verify ボタンをクリックすると，照合を行います。 

(7)  OK ボタンをクリックすると，本画面を閉じます。 
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項  目 内  容 

Module Information 
対象のユニットの情報（先頭スライスNo.，ユニット形名，ラベル名，ベースユニット

形名）を表示します。 
 
  OK ボタン 
 

本画面を閉じます。 

Online 対象のユニットに対して，操作を行います。 

 Select Data 読出し，書込み，および照合を行うパラメータを選択します。 

  
 
  Select All ボタン 
 

“パラメータ一覧”の“Select”にすべてチェックします。 

  
 
  Release All ボタン 
 

“パラメータ一覧”の“Select”からすべてチェックを外します。 

 Target Memory 読出し，書込み，および照合の対象とするメモリを選択します。 

 
 
  Upload ボタン 
 

“Target Memory”で選択したメモリから，対象のユニットのパラメータを読み出しま

す。 

同一のパラメータを複数のチャンネルで持つユニットの場合は，“Channel”で選択し

たチャンネルのパラメータを読み出します。 

読み出したパラメータは，“パラメータ一覧”に表示されます。 

 
 
  Download ボタン 
 

パラメータが間違っていないかをチェックし，間違っていない場合は，“Target 

Memory”で選択したメモリへ，パラメータを書き込みます。 

同一のパラメータを複数のチャンネルで持つユニットの場合は，“Channel”で選択し

たチャンネルのパラメータを書込みます。 

間違っている場合は，間違っているパラメータを書き込まずに，“パラメータ一覧”

の“Item”の項目を赤色で表示します。 

 
 
  Verify ボタン 
 

“Target Memory”で選択したメモリのパラメータと，“パラメータ一覧”のパラメー

タとを照合します。 

同一のパラメータを複数のチャンネルで持つユニットの場合は，“Channel”で選択し

たチャンネルのパラメータを照合します。 

照合した結果が不一致となったパラメータは，“パラメータ一覧”の“Item”の項目

を赤色で表示します。 

Channel 

読出し，書込み，または照合を行うパラメータのチャンネルを指定します。 

同一のパラメータを複数のチャンネルで持つユニットの場合のみ，本項目が表示され，

操作できます。 

パラメータ一覧 

ユニットが持つパラメータを一覧表示します。 

ユニットが持つパラメータの種類と用途については，各ユニットのマニュアルを参照

してください。 

 Select “Online”で操作を行うパラメータを選択します。 

 Item 

パラメータの名前を表示します。 

  Download ボタンまたは Verify ボタンの操作により，本項目を赤色で表示する場合

があります。 

詳細は，各項目の内容を参照してください。 

 Setting Value 

パラメータの値を表示します。 

本項目が灰色に表示されたパラメータは，書き込むことができません。 

読出しおよび照合は行うことができます。 
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8.8.4 パラメータのエラーチェック 

 

 
パラメータのエラーチェックを行い，パラメータのエラーを確認します。 

 

 
 

(1) 同一のパラメータを複数のチャンネルで持つユニットの場合は，エラーチェッ

クを行うパラメータのチャンネルを“Channel”で選択します。 

(2)  Error Check ボタンをクリックすると，エラーチェックを行います。 

(3)  OK ボタンをクリックすると，本画面を閉じます。 

 

 
 

 

 

 
 

項  目 内  容 

Module Information 
対象のユニットの情報（先頭スライスNo.，ユニット形名，ラベル名，ベースユニット

形名）を表示します。 
 
  OK ボタン 
 

本画面を閉じます。 

Channel 

エラーチェックを行うパラメータのチャンネルを指定します。 

同一のパラメータを複数のチャンネルで持つユニットの場合のみ，本項目を表示して

操作可能です。 

 
  Error Check ボタン 
 

パラメータが間違っていないかをチェックします。 

間違っている場合は，“パラメータ一覧”の“Item”の項目を赤色で表示します。 
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項  目 内  容 

パラメータ一覧 

ユニットが持つパラメータを一覧表示します。 

ユニットが持つパラメータの種類と用途については，各ユニットのマニュアルを参照

してください。 

 Item 

パラメータの名前を表示します。 

  Error Check ボタンの操作により，本項目を赤色で表示する場合があります。 

詳細は， Error Check ボタン の内容を参照してください。 
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8.9 オプション設定 

 

 
ラベル名，ベースユニットおよび最大入出力点数設定などを設定します。 

 

 
 

(1) 下記の操作の内，いずれかを実行します。 

・ [Edit]→[Option]メニューをクリックします。 

・ キーボードの F10 キーを押します。 

・ “Module Information List”画面のオプション設定を行うユニット上で

マウスを右クリックし，メニューから[Option]をクリックします。 

(2) 開いた画面でオプション設定を行い， OK ボタンをクリックします。 

 

  

   

“Module Information List”画面が表示された状態で操作を行ってください。 

“Module Information List”画面は，[View]→[Module Information List]メニュー

を選択すると表示されます。 
 

 

 
 

 

 

 
 

項  目 内  容 

Model Name オプション設定を行うユニットの製品形名を表示します。 

Label Name 

ユーザが自由に設定できる文字列を，半角英数32文字以内で入力します。 

“Module Information List”画面や印刷時などに表示／出力されますので，ユニット

を管理する時などに役立てることができます。 

Base Module＊1 スライスユニットの場合は，ベースユニットを選択します。 

Maximum Input/Output Points ヘッドユニットの場合は，最大入出力点数設定を設定します。 

Use Word Input Data 
 Wr.n ワード入力を持つユニットの場合は，チェックすると， Wr.n ワード入力を使

用できるように設定します。 

Use Word Output Data 
 Ww.n ワード出力を持つユニットの場合は，チェックすると， Ww.n ワード出力を使

用できるように設定します。 
 
  OK ボタン 
 

設定を有効にして，本画面を閉じます。 
 
  Cancel ボタン 
 

設定をキャンセルして，本画面を閉じます。 

＊1 適用ベースユニットについては，各ユニットのマニュアルを参照してください。 
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8.10 電源容量チェック 

 

 
各ユニットが必要とするDC5V内部消費電流の合計が，基本分配ユニットのDC5V最

大定格出力電流を越えてないかチェックします。 

 

  

   

本機能で使われている計算方法の詳細は，MELSEC-STシステムユーザーズマニュア

ルを参照してください。 
 

 

 
 

(1) 下記の操作の内，いずれかを実行します。 

・ [Edit]→[Power Distribution Check]メニューをクリックします。 

・ “Module Information List”画面の一覧上でマウスを右クリックし，メ

ニューから[Power Destribution Check]をクリックします。 

(2) 開いた画面でチェック結果を確認します。 

(3) 本画面を閉じる場合は， Close ボタンをクリックします。 

 

  

   

“Module Information List”画面を開いた状態で操作を行ってください。 

“Module Information List”画面は，[View]→[Module Information List]メニュー

を選択すると表示されます。 
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項  目 内  容 

No. 基本分配ユニットの装着位置を表示します。 

Supply Current(A) 基本分配ユニットのDC5V最大定格出力電流を表示します。 

Consumption(A) 
基本分配ユニットが電源を供給しているユニットの，DC5V内部消費電流の合計を表示

します。 

Result 

チェック結果を表示します。 

“OK” ：DC5V内部消費電流の合計が基本分配ユニットのDC5V最大定格出力電流を越

えていません。 

“ERROR”：DC5V内部消費電流の合計が基本分配ユニットのDC5V最大定格出力電流を越

えています。 
 
  Close ボタン 
 

本画面を閉じます。 
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９ パラメータの書込み，読出し 

各ユニットのパラメータを書込み，または読出しを行う方法を説明します。 

 

9.1 接続先指定 

 

 
ヘッドユニットとの接続について設定します。 

 

 
 

(1) [Online]→[Transfer Setup]メニューをクリックします。 

(2) 設定を行い， OK ボタンをクリックします。 

 

 
 

 

 

 
 

項  目 内  容 

COM Port 
ヘッドユニットと接続するCOMポートを選択します。 

（設定範囲：COM1～COM10，デフォルト*1：COM1） 

Transmission Speed 
伝送速度を選択します。 

（設定範囲：9.6kbps，19.2kbps，38.4kbps，57.6kbps，デフォルト*1：9.6kbps） 

Timeout*2 

ヘッドユニットと交信中にMELSEC-STシステムの外部電源OFFまたはヘッドユニットの

リセットなどを行った場合，交信エラーが表示されるまでの間，時間がかかります。

エラーが表示されるまでの間モニタは実行中を表示します。 

エラーが表示されるまでの最大の時間は下記で求められます。 

（“Timeout”の指定時間）×4 

例えば，“Timeout”の指定を5秒に指定している場合は，（5秒）×4＝20秒となり最

大20秒後にエラーが表示されます。 

（設定範囲：1～9，デフォルト*1：5） 
 
  OK ボタン 
 

設定を有効にして，本画面を閉じます。 

 
  Cancel ボタン 
 

設定を行わずに，本画面を閉じます。 

 
＊1：本画面を使用する回数がGX Configurator-STをインストールしてから2回目以降の場合は，デフォルトは前回本画面を

使用した時に設定した値となります。 

＊2：各ユニットのROMへ書き込むときに交信エラーが発生した場合，エラーが表示されるまでの時間は最大で30秒です。 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 9 
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ご使用のパソコンの種類によっては，“Transmission Speed”に19.2kbps以上の伝

送速度を設定すると，通信を失敗するなどの不安定な状態になり，下記の画面が表

示される場合があります。 

下記の画面が表示された場合は，伝送速度の設定を下げてください。 
 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 9 
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9.2 各種情報取得 

 

 
ユニット構成および各ユニットのパラメータを，各ユニットから読み出します。 

 

 
 

(1) [Online]→[Get System]メニュー（ ）をクリックします。 

(2) プロジェクトを開いている場合は，ユニット構成および各ユニットのパラメー

タを読み出すことで，先に読み出していたプロジェクトの情報が消去されま

す。 

このため，読出しを確認する画面が表示されます。 

・  Yes ボタンをクリックすると“Get System”画面が表示されます。 

この場合，読出しを行うときに先に読み出していたプロジェクトの情報は

消去されます。 

・  No ボタンをクリックすると処理を中止しします。 

(3) “Get System”画面にて読み出す内容を設定し， OK ボタンをクリックする

と，ユニット構成，および各ユニットのパラメータの読出しを行います。 

(4) 読出しが完了すると，“Completed”というメッセージが表示されます。 

 OK ボタンをクリックしてください。 

 

 
 

 

 

 
 

項  目 内  容 

Read Parameter 
チェックすると，各ユニットのパラメータを読み出すことを設定します。 

ユニット構成については，本項目の設定とは関係なく読み出します。 

 RAM 
各ユニットのRAMからパラメータを読み出すように設定します。 

“Read Parameter”をチェックしている場合のみ，本項目を操作可能です。 

 ROM 

各ユニットのROMからパラメータを読み出すように設定します。 

対象のユニットがROMを持たない場合は，RAMから読み出します。 

“Read Parameter”をチェックしている場合のみ，本項目を操作可能です。 
 
  OK ボタン 
 

読出しを行い，本画面を閉じます。 

 
  Cancel ボタン 
 

読出しを行わずに，本画面を閉じます。 
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9.3 入出力データ設定情報の読出し 

 

 
GX Configurator-DPにより設定された入出力データ設定情報を，各ユニットから

読み出します。 

読み出す入出力データ設定情報は下記の2項目です。 

・ヘッドユニットの最大入出力点数設定 

・インテリジェント機能ユニットの Wr.n ワード入力/ Ww.n ワード出力について，

使用／未使用の設定 

 

 
 

(1) [Online]→[Get Input/Output Data Settings]メニューをクリックします。 

(2) 読出しを実行することの確認画面が表示されます。 

 OK ボタンをクリックして，入出力データ設定情報の読出しを行います。 

(3) 読出しが完了すると，“Completed”というメッセージが表示されます。 

 OK ボタンをクリックしてください。 

 

 

9.4 パラメータの一括書込み 

 

 
パラメータを各ユニットに一括で書き込みます。 

 

 
 

(1) [Online]→[Parameter Block Write]メニューをクリックすると，“Parameter 

Block Write”画面が表示されます。 

(2) パラメータを書き込む先のメモリおよびパラメータを選択し， Download ボ

タンをクリックします。 

(3) 書込みが完了すると，“Download completed”というメッセージが表示され

ます。 

 OK ボタンをクリックしてください。 

(4) 本画面を閉じる場合は， Close ボタンをクリックします。 
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項  目 内  容 

Select Data パラメータの書込みを行うユニットを一括して選択します。 

 
 
  Select All ボタン 
 

すべてのユニットを選択します。 

 
 
  Release All ボタン 
 

すべてのユニットの選択を解除します。 

Target Memory 

パラメータを書き込むメモリを選択します。 

・“RAM”を選択した場合は，各ユニットのRAMへ書き込みます。 

・“ROM”を選択した場合は，各ユニットのROMへ書き込みます。 

・“RAM/ROM”を選択した場合は，各ユニットのRAMおよびROMへ書き込みます。 

 
  Download ボタン 
 

“Select”で選択したユニットのパラメータを書き込みます。 

書込みを行っている間は，本ボタンをクリックできません。 

 
  Cancel ボタン 
 

書込みを中断します。 

書込みを行っている間のみ，本ボタンをクリックできます。 

Select＊1 パラメータの書込みを行うユニットを選択します。 

No.＊1 ユニットのNo.を表示します。 

Module Name＊1 ユニット形名を表示します。 

Status＊1 
書込みの実行状態を表示します。 

実行状態の詳細は，本項(1)を参照してください。 

 
  Close ボタン 
 

本画面を閉じます。 

書込みを行っている間は，本ボタンをクリックできません。 
 
＊1：パラメータを編集できないユニットは書込みを行う必要がないため，灰色で表示してパラメータの書込みを行いませ

ん。 

 

(1) 書込みの実行状態 

書込みの実行状態の詳細を下記に示します。 
 

表  示 内  容 

－ 
パラメータを持たないユニット，または書込みを行わないユニット

を示します。 

Wait 書込みを行う前の状態を示します。 

Writing... 書込みを行っている状態を示します。 

Complete 書込みが完了した状態を示します。 

Error 書込みに失敗した状態を示します。 
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9.5 インテリジェント機能ユニットのオフセット・ゲイン設定 

 

  

   

本機能の詳細は，インテリジェント機能ユニットのマニュアルを参照してくださ

い。 
 
 

 

 
インテリジェント機能ユニット＊1のオフセット値またはゲイン値を設定します。 

＊1：オフセット値またはゲイン値を設定できるインテリジェント機能ユニットの

例を下記に示します。 
 

・ST1AD2-V ・ST1AD2-I 

・ST1DA2-V ・ST1DA1-I 
 

詳細は，インテリジェント機能ユニットのマニュアルを参照してください。 

 

 
 

(1) “System Monitor”画面にて，設定対象のインテリジェント機能ユニットを

選択します。 

(2) “System Monitor”画面にて，“Forced Output Test Mode”の ON ボタンを

クリックし，MELSEC-STシステムを強制出力テストモードに変更します。 

MELSEC-STシステムを強制出力テストモードに変更すると，ヘッドユニットの

RUN LEDが点滅します。 

(3) 下記の操作の内，いずれかを実行します。 

・ [Online]→[Offset/Gain Setting]メニューをクリックします。 

・ (1)にて選択したユニット上で右クリックし，メニューから 

[Offset/Gain Setting]をクリックします。 

・ “System Monitor”画面内の Offset/Gain Setting ボタンをクリックし

ます。 

(4) オフセット・ゲイン設定モードに変更することを確認するダイアログボック

スが表示されます。 

 OK ボタンをクリックして，オフセット・ゲイン設定モードに変更してくだ

さい。 

オフセット・ゲイン設定モードに切り換わると，設定対象のインテリジェン

ト機能ユニットのRUN LEDが点滅（0.5s間隔）し動作を停止します。 

(5) “Select Channel”で設定するチャンネルを選択し，“Connection Method”

でベースユニットの配線方式を選択し，設定する値を“Offset”または“Gain”

から選択します。 

(6) オフセット値またはゲイン値の調整量を設定し， Set ボタンをクリックしま

す。 

(6)の操作を繰り返して，希望の値に調整します。 

(7)  Save ボタンをクリックして，設定対象のインテリジェント機能ユニットに

オフセット値またはゲイン値を書き込みます。 

(8) 本画面を閉じる場合は， Close ボタンをクリックします。 
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(9) オフセット・ゲイン設定モードを解除することを確認するダイアログボック

スが表示されます。 

 Yes ボタンをクリックしてオフセット・ゲイン設定モードを解除してくださ

い。 

 

備  考 

(a) (3) の操作を行った段階で，MELSEC-STシステムが強制出力テストモードでない

場合は，強制出力テストモードに変更することを確認するダイアログボックス

が表示されます。 

 OK ボタンをクリックして，強制出力テストモードに変更してください。 

(b) (a)にてMELSEC-STシステムを強制出力テストモードに変更した場合は，(9)の操

作を行った後に，強制出力テストモードを解除することを確認するダイアログ

ボックスが表示されます。 

強制出力テストモードを解除する場合は， Yes ボタンをクリックしてください。 

解除しない場合は， No ボタンをクリックしてください。 

 

 
 

 

 

 
 

項  目 内  容 

Module Information 
設定対象のインテリジェント機能ユニットの情報（No.，先頭スライスNo.，ユニット

形名，ラベル名，ベースユニット）を表示します。 

Select Channel 

オフセット値またはゲイン値を設定するチャンネルを選択します。 

複数のチャンネルにチェックすると，チェックしたすべてのチャンネルに対してオフ

セット値またはゲイン値を設定します。 

本項目に表示するチャンネルは設定対象のユニットにより変わります。 

詳細は，インテリジェント機能ユニットのマニュアルを参照してください。 
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項  目 内  容 

Offset 

オフセット値の調整量を設定します。 

“Offset”のラジオボタンを選択している場合のみ，本項目を設定可能です。 

詳細は，インテリジェント機能ユニットのマニュアルを参照してください。 

Gain 

ゲイン値の調整量を設定します。 

“Gain”のラジオボタンを選択している場合のみ，本項目を設定可能です。 

詳細は，インテリジェント機能ユニットのマニュアルを参照してください。 

 
  Error Clear ボタン 
 

  Ew.n エラークリアビットをONにセットして，インテリジェント機能ユニットのエ

ラークリアを行います。 
 
  Set ボタン 
 

設定内容を対象のユニットに設定します。 

 
  Save ボタン 
 

  Set ボタンで設定した値を有効にします。 

 
  Close ボタン 
 

本画面を閉じて，オフセット・ゲイン設定モードを解除します。 

本画面を開いた時に，MELSEC-STシステムが強制出力テストモードではなかった場合

は，強制出力テストモードを解除できます。 
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10 モニタ，テスト 

ユニットのモニタおよびテストを行う方法について説明します。 

 

10.1 システムモニタ 

 

 
ヘッドユニットおよびスライスユニットの状態をモニタします。 

 

 
 

(1) “System Monitor”画面が表示されていない場合は，[View]→[System Monitor]

メニューをクリックすると，“System Monitor”画面が表示されます。 

(2) “System Monitor”画面は表示されると同時にモニタを開始します。 

(3) 本画面を閉じる場合は， Close ボタンをクリックします。 

 

  

   

パソコンと接続したMELSEC-STシステムのユニット構成と，プロジェクトのユニッ

ト構成とが違っている場合，“System Monitor”画面は表示されません。 

ユニット構成が違っていないことを確認してから“System Monitor”画面を表示さ

せてください。 
 
 

 

 
エラーが発生しているユニットを確認する場合は，“System Monitor”画面で下

記の操作を行います。 

(1) “Select Module”にて，赤色または黄色で表示された箇所を確認します。 

(2) (1)で確認した箇所に対応する， Display Position ボタンをクリックします。 

(3) “ユニット表示部”の“Module Status”が，赤色または黄色で表示されたユ

ニットがエラーの発生しているユニットです。 

“ユニット表示部”をスクロールさせて，“ユニット表示部”の“Module 

Status”が赤色または黄色で表示されたユニットを確認します。 
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項  目 内  容 

Module Information 
“ユニット表示部”で選択したユニットの情報（ユニット形名，ラベル名，ベースユ

ニット）を表示します。 

Communication Status With Master 

Station 

ヘッドユニットとマスタ局間の交信状態を示します。 

“Communicating”          ：マスタ局と交信中 

“Communication suspended”：マスタ局と交信中断（交信断） 

“No Communication”       ：マスタ局と交信停止（未交信） 

Module Status 

“Select Modules”，および“ユニット表示部”内の“Module Status”で，表示する

色の見本を表示します。 

赤色：システムエラー 

黄色：ワーニング 

紫色：オンラインユニット交換中 

ユニット表示部 

モニタを行っているMELSEC-STシステムの，イメージイラストを表示します。 

ユニットの選択が必要な機能を使う場合は，本項目で表示しているユニットをクリッ

クして選択します。 

ユニット上部の“Module Status”にはスライスユニットの動作状態を表示します。

ユニットの状態の詳細は，本節(1)を参照してください。 

Select Module 

数字はユニットのNo.を示しており，その範囲内にあるユニットの状態を表示し，“ユ

ニット表示部”に表示するユニットを変更できます。 

ユニットの状態の詳細は，本節(1)を参照してください。 

 
 
  Display Position ボタン 
 

本ボタン左隣の数字はユニットのNo.を示しており，そのNo.のユニットを“ユニット

表示部”に表示します。 
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項  目 内  容 

Monitor Switch モニタの開始／停止を行います。 

 
 
  Start ボタン 
 

モニタを開始します。 

モニタ停止中のみ，本項目を操作可能です。 

モニタ中は本ボタンの左側で“ ”が点滅します。 

 

 
 
  Stop ボタン 
 

モニタを停止します。 

モニタ中のみ，本項目を操作可能です。 

Forced Output Test Mode 

MELSEC-STシステムを強制出力テストモードに設定または解除し，現在のモード状態を

表示します。 

 

 
 
  ON ボタン 
 

MELSEC-STシステムを強制出力テストモードに設定します。 

 
 
  OFF ボタン 
 

MELSEC-STシステムを強制出力テストモードから解除します。 

 
  Input/Output Monitor ボタン 
 

“ユニット表示部”で選択したユニットの，入力送信データおよび出力受信データを

モニタします。 

詳細は，10.3節を参照してください。 

ユニットを選択していない場合は，エラーメッセージが表示され，モニタを実行でき

ません。 

 
  Forced Output Test ボタン 
 

“ユニット表示部”で選択したヘッドユニット，出力ユニットまたはインテリジェン

ト機能ユニットにて，強制出力テストを行います。 

詳細は，10.4節を参照してください。 

ユニットを選択していない場合は，エラーメッセージが表示され，強制出力テストを

実行できません。 

 
  Offset/Gain Setting ボタン 
 

“ユニット表示部”で選択したオフセット値またはゲイン値を設定できるインテリ

ジェント機能ユニットに，それぞれの値を設定します。 

詳細は，9.5節を参照してください。 

ユニットを選択していない場合は，エラーメッセージが表示され，オフセット値また

はゲイン値の設定を実行できません。 

 
  Module Detail Information  

ボタン 
 

“ユニット表示部”で選択したユニットの，詳細情報およびエラー状態をモニタしま

す。 

詳細は，10.2節を参照してください。 

ユニットを選択していない場合は，エラーメッセージが表示され，モニタを実行でき

ません。 

 
  Online Module Change ボタン 
 

“ユニット表示部”で選択した入出力ユニットおよびインテリジェント機能ユニット

のオンラインユニット交換を行います。 

詳細は，11.2節を参照してください。 

ユニットを選択していない場合は，エラーメッセージが表示され，オンラインユニッ

ト交換を実行できません。 

 
  Parameter Setting ボタン 
 

“ユニット表示部”で選択したヘッドユニット，入出力ユニット，またはインテリジェ

ント機能ユニットの，パラメータの設定を行います。 

詳細は，8.8節を参照してください。 

ユニットを選択していない場合は，エラーメッセージが表示され，パラメータの設定

を実行できません。 
 
  Close ボタン 
 

本画面を閉じます。 
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(1) ユニットの状態 

ユニットの状態の詳細を下記に示します。 
 

表  示 内  容 

赤  色 
システムエラーが発生 

エラーの詳細は，各ユニットのマニュアルを参照してください。 

黄  色 
ワーニングが発生 

ワーニングの詳細は，各ユニットのマニュアルを参照してください。

紫  色 オンラインユニット交換中 

灰  色 
ユニット未装着 

灰色は，“Select Module”にのみ表示されます。 

白  色 正常運転中 

 

  

   

本画面でモニタ停止中にスライスユニットを他の種類のユニットに交換した場合，

モニタを再開すると“Module Status”覧には交換したユニットとそのユニットよ

りNo.が大きいユニットの項目が赤色で表示されます。 
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10.2 ユニット詳細情報 

 

 
ユニットの，詳細情報，動作状態およびエラー状態をモニタします。 

 

 
 

(1) “System Monitor”画面にてモニタを行うユニットを選択します。 

(2) 下記の操作の内いずれかを実行すると，“Module Detail Information”画面

が表示されてモニタが開始されます。 

・ [Diagnostics]→[Module Detail Information]メニューをクリックします。 

・ (1)にて選択したユニット上でマウスを右クリックし，メニューから

[Module Detail Information]をクリックします。 

・ “System Monitor”画面内の Module Detail Information ボタンをクリッ

クします。 

(3) 動作状態またはエラー情報を更新する場合は， Refresh ボタンをクリックし

てください。 

(4) 本画面を閉じる場合は， Close ボタンをクリックします。 
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項  目 内  容 

Module Detail Information 

モニタする対象ユニットの情報が表示されます。 

本項目に表示する項目を下記に示します。 

・先頭スライスNo.
＊1

 

・ユニット形名 

・ラベル名 

・局番
＊2 

ヘッドユニットの局番設定スイッチで設定した局番が，局番の設定範囲外（100以降

を設定している場合は“---”が表示されます。 

詳細は，本画面の“Current Error/Status”または“Error/Status Log”を参照し

てください。 

・ベースユニット形名
＊1

 

・バージョン 

ヘッドユニットおよびインテリジェント機能ユニットの場合は，各ユニットのバー

ジョンが表示されます。 

電源分配ユニットおよび入出力ユニットの場合は，“- - -”が表示されます。 

・最大入出力点数設定
＊2

 

・伝送速度
＊2

 

MELSEC-STシステムがマスタ局と未交信の場合は，“--”が表示されます。 

・ Br.n ビット入力
＊1

／ Bw.n ビット出力
＊1 

／ Wr.n ワード入力
＊1，＊3

／ Ww.n ワード出力
＊1，＊3

 

Current Error/Status＊2，＊4 ヘッドユニットの現在の動作状態またはエラー情報が表示されます。 

 No.(HEX) エラーコードが16進数で表示されます。 

 Current Error/Status 動作状態またはエラー内容が表示されます。 

Current Error＊1，＊4 対象ユニットの現在の動作状態またはエラー情報が表示されます。 

 No.(HEX) エラーコードが16進数で表示されます。 

 Current Error/Status 動作状態またはエラー内容が表示されます。 

Error/Status Log＊2，＊4 

ヘッドユニットの動作状態またはエラーの履歴が表示されます。 

下の行から上の行に向かって新しい履歴が表示されます。 

本項目には，最大5件分の履歴が表示されます。 

6件目以降に情報を追加する時は，一番古い情報から削除されます。 

MELSEC-STシステムの外部電源OFFまたはヘッドユニットをリセットすると，本項目の

内容は消去されます。 

 No.(HEX) エラーコードが16進数で表示されます。 

 Error/Status Log 動作状態またはエラー内容が表示されます。 
 
  Refresh ボタン 
 

“Current Error/Status”および“Error/Status Log”の内容が更新されます。 

 
  Close ボタン 
 

本画面を閉じます。 

 
  Clear Log ボタン＊2 
 

“Error/Status Log”の内容を消去します。 

“Current Error/Status”の内容は消去されません。 
 
＊1：本項目は，電源分配ユニット，入出力ユニットまたはインテリジェント機能ユニットの場合に表示されます。 

＊2：本項目は，ヘッドユニットの場合に表示されます。 

＊3： Wr.n ワード入力／ Ww.n ワード出力は，対象のユニットが各項目を占有しない場合は“-”を表示します。 

＊4：エラーの詳細は，各ユニットのマニュアルを参照してください。 
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10.3 入出力データ診断 

 

 
ユニットの，入力送信データおよび出力受信データをモニタします。 

 

 
 

(1) “System Monitor”画面にてモニタを行うユニットを選択します。 

(2) 下記の操作の内いずれかを実行すると，“Input/Output Monitor”画面が表

示されてモニタが開始されます。 

・ [Online]→[Input/Output Monitor]メニューをクリックします。 

・ (1)にて選択したユニット上でマウスを右クリックし，メニューから

[Input/Output Monitor]をクリックします。 

・ “System Monitor”画面内の Input/Output Monitor ボタンをクリックし

ます。 

(3) 本画面を閉じる場合は， Close ボタンをクリックします。 
 

 

 

 

 

 
 

項  目 内  容 

Monitor Switch モニタの開始／停止を行います。 

 
 
  Start ボタン 
 

モニタを開始します。 

モニタ停止中のみ，本ボタンを操作可能です。 

モニタ中は本ボタンの左側で“ ”が点滅します。 

 

 
 
  Stop ボタン 
 

モニタを停止します。 

モニタ中のみ，本ボタンを操作可能です。 
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項  目 内  容 
 
  Close ボタン 
 

本画面を閉じます。 

Monitor Information 
モニタするユニットの情報（先頭スライスNo.，ユニット形名，ラベル名）を表示しま

す。 

Bit Data＊1, ＊2 対象のユニットが持つビット単位の入出力データを表示します。 

Word Data＊1, ＊2 

対象ユニットがインテリジェント機能ユニットの場合は， Wr.n ワード入力の値およ

び 

 Ww.n ワード出力の値を表示します。 

ラジオボタンのDEC/HEXを選択することで，“Value”表示されている値を10進数また

は16進数で表示します。 

DEC：10進数 

HEX：16進数 
 
＊1：各データの詳細は，各ユニットのマニュアルを参照してください。 

＊2：MELSEC-STシステムが強制出力テストモードの場合，“Forced Output Test”画面で入力した値が表示されます。 
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10.4 強制出力テスト 

 

 
ヘッドユニットおよびスライスユニットの， Bw.n ビット出力， Ww.n ワード出

力および Ew.n エラークリアビットを，PROFIBUS-DPネットワークを止めずに出力

テストします。 

 

 
 

(1) “System Monitor”画面にてモニタを行うユニットを選択します。 

(2) “System Monitor”画面にて，“Forced Output Test Mode”の ON ボタンを

クリックすると，MELSEC-STシステムを強制出力テストモードに変更すること

を確認する画面が表示されます。 

 Yes ボタンをクリックして，MELSEC-STシステムを強制出力テストモードに

変更します。 

MELSEC-STシステムを強制出力テストモードに変更すると，ヘッドユニットの

RUN LEDが点滅します。 

(3) 下記の操作の内いずれかを実行すると，“Forced Output Test”画面が表示

されます。 

・ [Online]→[Forced Output Test]メニューをクリックします。 

・ (1)にて選択したユニット上でマウスを右クリックし，メニューから

[Forced Output Test]をクリックします。 

・ “System Monitor”画面内の Forced Output Test ボタンをクリックしま

す。 

(4) “Forced Output Test”画面で，強制出力テストを行う項目の選択およびデー

タの設定を行い， Settings ボタンをクリックして強制出力テストを行いま

す。 

(5) 強制出力テストが完了すると，“Completed”というメッセージが表示されま

す。 

 OK ボタンをクリックしてください。 

(6) 本画面を閉じる場合は， Close ボタンをクリックします。 

(7) “System Monitor”画面にて，“Forced Output Test Mode”の OFF ボタン

をクリックし，MELSEC-STシステムを強制出力テストモードから解除します。 
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(1) 強制出力テストで， Bw.n+1 変換設定要求， Bw.n+3 ， Bw.n+2 CH□出力許可

／禁止のON/OFF， Ww.n ， Ww.n+1 CH□ディジタル値設定を変更するとアナロ

グ出力が変化しますので，十分に安全を確認してから行ってください。 

(2) MELSEC-STシステムとマスタ局との交信が切断された場合に，CH□ クリア／

ホールド／プリセット指定にホールドを設定しているインテリジェント機能

ユニットの， Bw.n+1 変換設定要求を強制出力テストでON→OFFに変更すると，

 Ww.n ワード出力の値が0になります。 

この場合，強制出力テストモードを解除しても Ww.n ワード出力の値は保持し

ていた値に戻りません。 
 

 

備  考 

(a) (4)にて Settings ボタンをクリックしたときにMELSEC-STシステムが強制出力

テストモードでない場合は，強制出力テストモードへ変更することを確認する

画面が表示されます。 

 OK ボタンをクリックすると，強制出力テストモードに変更し，強制出力テス

トを行います。 

(b) (a)にてMELSEC-STシステムを強制出力テストモードに変更した場合は，(6)の操

作を行った後に強制出力テストモードを解除することの確認画面が表示されま

す。 

強制出力テストモードを解除する場合は Yes ボタンをクリックしてください。 

解除しない場合は No ボタンをクリックしてください。 
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項  目 内  容 
 
  Select All ボタン 
 

“Bit Data”および“Word Data”のすべての“Select”にチェックされます。 

 
  Release All ボタン 
 

“Bit Data”および“Word Data”のすべての“Select”からチェックがはずされます。

 
  Settings ボタン 
 

“Select”にチェックされている Bw.n ビット出力， Ww.n ワード出力および Ew.n 

エラークリアビットを強制出力テストします。 

強制出力テストが完了すると，“Completed”というメッセージが表示されます。 

 
  Close ボタン 
 

本画面を閉じます。 

本画面を開いた時に，MELSEC-STシステムが強制出力テストモードではなかった場合

は，強制出力テストモードを解除する画面が表示されます。 

Module Information 
強制出力テストを行うユニットの情報（先頭スライスNo.，ユニット形名，ラベル名）

を表示します。 

Bit Data＊1 
強制出力テストを行うビットデータを“Select”にチェックして選択し，出力するビッ

ト値を“Value”に設定します。 

Word Data＊1 

強制出力テストを行うワードデータを“Select”にチェックして選択し，出力するワー

ド値を“Value”に設定します。 

ラジオボタンのDEC/HEXを選択することで，“Value”の入力形式を10進数または16進

数に切り換えます。 

DEC：10進数 

HEX：16進数 
 
＊1：各データの詳細は，各ユニットのマニュアルを参照してください。 
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10.5 マスタ局との交信データモニタ 

10.5.1 マスタ局との交信データモニタ 

 

 
PROFIBUS-DPのマスタ局とスレーブ局（ヘッドユニット）間の入出力データをモニ

タします。 

 

 
 

(1) [Diagnostics]→[Master Station Data Communication Monitor]メニューを

クリックすると，“Master Station Data Communication Monitor”画面が表

示されてモニタを開始します。 

(2) “データ表示部”に表示する入出力データを，“Select Area”で選択します。 

(3) モニタしたデータをテキストファイルに保存する場合は， Stop ボタンをク

リックしてモニタを停止し， Copy to File ボタンをクリックします。 

詳細は，10.5.2項を参照してください。 

(4) 本画面を閉じる場合は， Close ボタンをクリックします。 

 

 
 

 

 



 

 

 

10 - 13                                         10 - 13 

10 モニタ，テスト 
MELSOFT

 

 
 

項  目 内  容 

Select Area＊1 

“データ表示部”に表示する入出力データを下記の項目から選択します。 

All Area   ：入出力データ全体 

Bit Output Area  ： Bw ビット出力エリア 

Error Clear Area  ： Ew エラークリアビットエリア 

System Area  ： Sw システムエリア 

Command Execution Area ： Cw コマンド実行エリア 

Word Output Area  ： Ww ワード出力エリア 

Bit Input Area  ： Br ビット入力エリア 

Error Information Area ： Er エラー情報ビットエリア 

Module Status Area ： Mr ユニット有無情報エリア 

Command Result Area ： Cr コマンド結果エリア 

Word Input Area  ： Wr ワード入力エリア 

 
  Copy to File ボタン 
 

モニタしたデータをテキストファイルに保存します。 

詳細は，10.5.2項を参照してください。 

モニタ中は本ボタンをクリックできません。 

  Stop ボタンをクリックしてモニタを停止させてから，保存してください。 
 
  Close ボタン 
 

本画面を閉じます。 

Word data 

 
  Copy to File ボタンで保存するテキストファイル，および“データ表示部”のワー

ド値の表現を変更します。 

 DEC(signed) 符号付きの10進数で表示します。 

 DEC(unsigned) 符号なしの10進数で表示します。 

 HEX 先頭に“H”を付けた16進数で表示します。 

Monitor モニタの開始／停止を行います。 

 
 
  Start ボタン 
 

モニタを開始します。 

モニタ停止中のみ，本項目を操作可能です。 

モニタ中は本ボタンの左側で“ ”が点滅します。 

 

 
 
  Stop ボタン 
 

モニタを停止します。 

モニタ中のみ，本項目を操作可能です。 

データ表示部＊1 

“Select Area”で選択したデータ領域のデータを表示します。 

“Address”は“Select Area”で選択したデータの，先頭アドレスを0番地としたオフ

セットアドレスです。 
 
＊1：入出力データの詳細は，ヘッドユニットのマニュアルを参照してください。 

 

備  考 

ユニットごとにデータを確認する場合は，“Input/Output Monitor”画面を使用し

てください。 

詳細は，10.3節を参照してください。 
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10.5.2 交信データの保存 

 

 
10.5.1項の“Master Station Data Communication Monitor”画面でモニタした入

出力データをテキストファイルに保存します。 

 

 
 

(1) “Master Station Data Communication Monitor”画面にて， Stop ボタンを

クリックしてモニタを停止させてから， Copy to File ボタンをクリックし

ます。 

(2) 保存先のディレクトリとファイル名を設定して Save ボタンをクリックする

と，モニタしたデータをテキストファイルに保存して，本画面を閉じます。 

 

 
 

 

 

 
 

項  目 内  容 

Save in モニタしたデータを保存するディレクトリを選択します。 

File name モニタしたデータのファイル名を設定します。 
 
  Save ボタン 
 

“File name”に指定したファイル名で，プロジェクトを保存します。 

 
  Cancel ボタン 
 

プロジェクトを保存せずに，本画面を閉じます。 

 

(1) 保存するテキストファイルの例 

保存するテキストファイルの例を下記に示します。 
 

 GX Configurator-ST Master Station Data Communication Monitor 

 Monitor Data : All Area 

 0000 : 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  : H0000 

 0001 : 0 1 0 1 0 1 0 1 0 1 0 0 0 0 0 0  : H5540 

 0002 : 0 0 0 0 0 0 0 0 0 0 0 1 0 1 0 1  : H0015 

 0003 : 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  : H0000 

 0004 : 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0  : H0000 

            ・ 

            ・ 

            ・ 
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10.6 PROFIBUS-DPネットワークパラメータモニタ 

10.6.1 PROFIBUS-DPネットワークパラメータモニタ 

 

 
PROFIBUS-DPのマスタ局からMELSEC-STシステムに送信された，スレーブパラメー

タおよびPROFIBUS-DPネットワークパラメータについて確認できます。 

 

 
 

(1) [Diagnostics]→[PROFIBUS-DP Network Parameter Monitor]メニューをクリッ

クすると，“PROFIBUS-DP Network Parameter Monitor”画面が表示されてモ

ニタを開始します。 

(2) モニタしたデータをテキストファイルに保存する場合は， Stop ボタンをク

リックしてモニタを停止させてから Copy to File ボタンをクリックします。 

詳細は，10.6.2項を参照してください。 

(3) 本画面を閉じる場合は， Close ボタンをクリックします。 

 

 
 

 

 

 
 

項  目 内  容 

Monitor モニタの開始／停止を行います。 

 
 
  Start ボタン 
 

モニタを開始します。 

モニタ停止中のみ，本項目を操作可能です。 

モニタ中は本ボタンの左側で“ ”が点滅します。 

 

 
 
  Stop ボタン 
 

モニタを停止します。 

モニタ中のみ，本項目を操作可能です。 
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項  目 内  容 

 
  Copy to File ボタン 
 

モニタしたデータをテキストファイルに保存します。 

詳細は，10.6.2項を参照してください。 

モニタ中は本ボタンをクリックできません。 

  Stop ボタンをクリックしてモニタを停止させてから，保存してください。 
 
  Close ボタン 
 

本画面を閉じます。 

データ表示部＊1 

PROFIBUS-DPのマスタ局からMELSEC-STシステムに送信された，スライスユニットのパ

ラメータおよびPROFIBUS-DPのパラメータを表示します。 

“Address”はモニタしたパラメータの，先頭アドレスを0番地としたオフセットアド

レスです。 
 
＊1：データの詳細は，ご使用のマスタ局またはコンフィグレーションソフトウェアのマニュアルを参照してください。 

 

 

10.6.2 PROFIBUS-DPネットワークパラメータモニタの保存 

 

 
10.6.1項の“PROFIBUS-DP Network Parameter Monitor”画面でモニタしたデータ

をテキストファイルに保存します。 

 

 
 

(1) “PROFIBUS-DP Network Parameter Monitor”画面にて， Stop ボタンをクリッ

クしてモニタを停止させてから Copy to File ボタンをクリックします。 

(2) 保存先のディレクトリとファイル名を設定して Save ボタンをクリックする

と，モニタしたデータをテキストファイルに保存して，本画面を閉じます。 

 

 
 

 

 

 
 

項  目 内  容 

Save in モニタしたデータを保存するディレクトリを選択します。 

File name モニタしたデータのファイル名を設定します。 
 
  Save ボタン 
 

“File name”に指定したファイル名で，プロジェクトを保存します。 

 
  Cancel ボタン 
 

プロジェクトを保存せずに，本画面を閉じます。 
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(1) 保存するテキストファイルの例 

保存するテキストファイルの例を下記に示します。 
 

 GX Configurator-ST PROFIBUS-DP Network Parameter Monitor 

 

 0000 : 88 05 01 0B DD 06 00 00 12 30 80 97 00 00 00 00  

 0001 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 0002 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 0003 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 0004 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 0005 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 0006 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 0007 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 0008 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 0009 : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 000A : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 000B : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  

 000C : 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  
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11 オンライン時のユニット操作 

オンライン時（MELSEC-STシステムとパソコンを接続した状態）で，GX 

Configurator-STから各ユニットを操作する機能について説明します。 

 

11.1 ヘッドユニットのリセット 

 

 
GX Configurator-STからヘッドユニットのリセットを行います。 

 

 
 

(1) [Online]→[Reset Head Module]メニューをクリックします。 

(2) モニタ中のウィンドウがある場合は，モニタの停止を確認する画面が表示さ

れます。 

 OK ボタンをクリックすると，モニタを停止します。 

(3) ヘッドユニットのリセットを，確認する画面が表示されます。 

 OK ボタンをクリックしてヘッドユニットをリセットし，リセットされたこ

とをLEDの点灯状態から確認します。 

ヘッドユニットはリセット中にはすべてのLEDが消灯し，リセットが完了する

と再度LEDが転送します。 

すべてのLEDが消灯した後に，再度LEDが点灯することを確認します。 

(4) ヘッドユニットに対してリセットの要求を発行したことを，確認する画面が

表示されます。 

 OK ボタンをクリックします。 

(5) (2)にてモニタを停止した場合は，モニタの再開を確認するメッセージが表示

されます。 

モニタを再開する場合は， Yes ボタンをクリックしてください。 

モニタを停止させたままにする場合は， No ボタンをクリックしてください。 

 

 

11 
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11.2 オンラインユニット交換 

(1) オンラインユニット交換機能について 

MELSEC-STシステムを停止することなく，入出力ユニットおよびインテリジェント

機能ユニットの交換を行うことができます。 

オンラインユニット交換は，ヘッドユニットのボタン操作またはGX 

Configurator-STから実行可能です。 

本節では，GX Configurator-STからオンラインユニット交換を行う方法を説明し

ます。 

 

11.2.1 オンラインユニット交換時の注意事項 

オンラインユニット交換時の注意事項について説明します。 

 

(1) オンラインユニット交換を行う場合は，オンラインユニット交換が実行可能なシ

ステム構成とする必要があります。 

詳細については，MELSEC-STシステムユーザーズマニュアル“3.4節 システム構

成上の注意事項”を参照してください。 

オンラインユニット交換が実行不可能なシステム構成で，オンラインユニット交

換を実行した場合，誤動作，故障の原因となります。 

オンラインユニット交換が実行不可能なシステム構成の場合は，MELSEC-STシステ

ムの外部電源を全相遮断し，スライスユニットの交換を行ってください。 

 

(2) オンラインユニット交換を行う場合は，必ず11.2.2項で示す手順で行ってくださ

い。 

11.2.2項に示す手順で行われない場合，誤動作，故障の原因となります。 

 

(3) オンラインユニット交換は，交換を行うスライスユニットに接続された外部機器

が誤動作しないことを確認して行ってください。 

また，交換を行うスライスユニットの Bw.n ビット出力および Ww.n ワード出力

を交換前にあらかじめ0(OFF)にすることをお薦めします。 

 

(4) オンラインユニット交換は，同一形名のスライスユニットへのみ交換可能です。 

別形名のスライスユニットへの変更およびスライスユニットの追加は行うことが

できません。 

 

(5) 1回のオンラインユニット交換で交換可能なスライスユニットは，1台のみです。 

複数のスライスユニットを交換する場合は，1台ずつオンラインユニット交換を

行ってください。 

 

(6) オンラインユニット交換では，入出力ユニット，インテリジェント機能ユニット

のみ交換可能です。 

電源分配ユニットおよびベースユニットの交換はできません。 

電源分配ユニットおよびベースユニットの着脱は，外部電源を全相遮断してから

行ってください。 

全相遮断しないとMELSEC-STシステムの全製品を損傷する恐れがあります。 
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(7) オンラインユニット交換中（ヘッドユニットのREL. LEDが点灯中）に，マスタ局

からオンラインユニット交換中のスライスユニットへのコマンドは実行できませ

ん。 

オンラインユニット交換中（ヘッドユニットのREL. LEDが点灯中）に，マスタ局

からオンラインユニット交換中のスライスユニットへコマンドを実行した場合，

エラーが発生します。 

 

(8) マスタ局からオンラインユニット交換中（ヘッドユニットREL. LEDが点灯中）の

スライスユニットのユーザパラメータを変更する場合は，オンラインユニット交

換が完了してから変更するようにしてください。 

オンラインユニット交換中にマスタ局からユーザパラメータを変更した場合，オ

ンラインユニット交換終了時に，変更したユーザパラメータにヘッドユニット内

に待避していたユーザパラメータを上書きするため，設定内容は有効にはなりま

せん。 

 

(9) オンラインユニット交換中のヘッドユニットのERR. LEDは，オンラインユニット

交換に関係するエラーが発生した場合のみ点灯します。 

オンラインユニット交換以外のエラーでは点灯または点滅しません。 

 

(10)オンラインユニット交換中（ヘッドユニットのREL. LEDが点灯中）は，オンライ

ンユニット交換を行っているスライスユニットの下記データはすべて0(OFF)とな

ります。 

・ Br.n ビット入力 

・ Er.n エラー情報ビット 

・ Mr.n ユニット有無情報 

・ Wr.n ワード入力 

 

(11)マスタ局との交信が切断されている状態で，出力ユニットのクリア／ホールド設

定にホールドを設定している，出力ユニットをオンラインユニット交換すると， 

 Bw.n ビット出力の値が0(OFF)となります。 

オンラインユニット交換終了後， Bw.n ビット出力の値はホールドしていた値に

は戻りません。 

 

(12)オンラインユニット交換中のスライスユニットに対しての強制出力テストは， 

 Ew.n エラークリアビットのみ実行可能です。 

 Bw.n ビット出力および Ww.n ワード出力を強制出力することはできません。 
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11.2.2 オンラインユニット交換の手順 

オンラインユニット交換の手順について説明します。 

オンラインユニット交換は，下記に示す手順に従って行ってください。 
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11.2.3 GX Configurator-STからオンラインユニット交換を行う場合 

GX Configurator-STからオンラインユニット交換を行う場合の手順について説明し

ます。 
 

  

   

オンラインユニット交換を行いたいスライスユニットと異なるスライスユニット

を選択してしまった場合，下記に示す操作を行ってください。 

(1) ③の画面表示中に気づいた場合 

③の画面の Cancel ボタンをクリックし，オンラインユニット交換を終了して

ください。 

(2) ④の画面表示中に気づいた場合 

スライスユニットの交換を行わずに Next ボタンをクリックし，⑩の操作まで

すべて行い，オンラインユニット交換を一度完了させてください。 

(3) ⑧の操作中に気づいた場合 

取り外したスライスユニットを再度装着して Next ボタンをクリックし，⑩の

操作まですべて行い，オンラインユニット交換を一度完了させてください。 
 

 スライスユニットの交換の準備 

① “System Monitor”画面にてオンラインユニット交換を行うス

ライスユニットを選択してください。 

↓  

 

② “System Monitor”画面内の Online Module Change ボタンを

クリックしてください。 

 Online Module Change ボタンをクリック後，オンラインユ

ニット交換を行うスライスユニットのRUN LEDが点滅（0.25s間

隔）していることを確認してください。 
 
備  考 

上記操作以外に下記の操作でも実行可能です。 

・ [Diagnostics]→[Online Module Change]メニューをクリック

します。 

・ ①にて選択したスライスユニット上でマウスを右クリックし，

メニューから[Online Module Change]をクリックします。 

↓ 
（次のページへ） 
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（前ページより） 

↓ 

 

③ “Target Module”に表示されたスライスユニットが，交換す

るスライスユニットに間違いないことを確認し， Next ボタン

をクリックしてください。 

 

(a) Next ボタンをクリックした場合は，交換するスライスユ

ニットを決定し，ヘッドユニットにて下記の処理が行われま

す。 

・ヘッドユニットがオンラインユニット交換モードに変更さ

れます。 

・交換するスライスユニットのユーザパラメータおよびコマ

ンドパラメータをヘッドユニットに待避します。 
 

(b) Next ボタンをクリックした後，各ユニットが下記の状態

になっていることを確認してください。 

・ヘッドユニットのREL. LEDが点灯 

・交換するスライスユニットのRUN LEDが消灯 

・“System Monitor”画面にてモニタ中の場合，交換するス

ライスユニットの“Module Status”の表示が紫色に変化

 

(c)スライスユニットからユーザパラメータおよびコマンドパ

ラメータを読出せなかった場合，ヘッドユニットのREL. LED

およびERR. LEDが点灯し，⑧の操作で画面上にエラーメッ

セージが表示されます。 

エラー内容を確認し，処置を行ってください。 

エラーコードの読出し操作およびエラーコードの詳細は

ヘッドユニットのマニュアルを参照してください。 

 

オンラインユニット交換を実行しない場合は， Cancel ボタン

をクリックしてください。 

 

(a) Cancel ボタンをクリックした場合は，オンラインユニッ

ト交換を中止したことが画面に表示されます。 

 

 Exit ボタンをクリックすると，②の操作を行う前の状態に戻

ります。 

↓ 

（次のページへ） 

 

 



 

 

 

11 - 7                                         11 - 7 

11 オンライン時のユニット操作 
MELSOFT

 

（前ページより） 

↓ 

 

 外部機器との切断 

④ 左記の画面が表示されたら，オンラインユニット交換を行うス

ライスユニットに接続されている外部機器を切断してくださ

い。 

詳細については，各スライスユニットのマニュアルの“オンラ

インユニット交換時の外部機器との切断，接続手順”を参照し

てください。 

 

  

  

各スライスユニットのマニュアルに記載の外部機器との切

断方法が実行できない場合は，MELSEC-STシステムの外部電

源を全相遮断し，スライスユニットの交換を行ってくださ

い。 

  

↓  

 スライスユニットの交換 

 

⑤ オンラインユニット交換を行うスライスユニットを，ベースユ

ニットから取り外してください。 

⑥ 取り外したスライスユニットと同一形名の新しいスライスユ

ニットをベースユニットへ装着してください。 

↓ 

（次のページへ） 
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（前ページより） 

↓ 

 

 スライスユニット交換後の外部機器との接続 

 

⑦ 新しいスライスユニットの装着後，外部機器との接続を行って

ください。詳細については，各スライスユニットのマニュアル

の“オンラインユニット交換時の外部機器との切断，接続手順”

を参照してください。 

↓  

 外部機器接続後の処理 

 ⑧ 外部機器との接続後，④の画面で Next ボタンをクリックして

ください。 
 

(a) Next ボタンをクリックした場合は，下記の処理が行われ

ます。 

・取り付けたスライスユニットが，取り外したスライスユ

ニットと同一形名のスライスユニットかをチェックしま

す。 

・③でヘッドユニットに待避したユーザパラメータおよびコ

マンドパラメータを，取り付けたスライスユニットに書込

みます。 
 

(b) Next ボタンをクリックした後，各ユニットが下記の状態

になっていることを確認してください。 

・ヘッドユニットのREL. LEDの点滅 

・取り付けたスライスユニットのRUN LEDの点滅（0.25s間隔）
 

 Cancel ボタンをクリックしてオンラインユニット交換を中

断した場合，オンラインユニット交換再開時の①の操作で，中

断前と同一のスライスユニットを選択し，オンラインユニット

交換を完了させてください。 

異なるスライスユニットを選択した場合，エラーが発生しま

す。 
 

③の操作で，交換前のスライスユニットからユーザパラメータ

およびコマンドパラメータを読み出せなかった場合，ヘッドユ

ニットのREL. LEDおよびERR. LEDが点灯し，GX Configurator-ST

で左記画面が表示されます。 

エラー内容を確認し，処置を行ってください。 

エラーコードの読出し操作およびエラーコードの詳細はヘッ

ドユニットのマニュアルを参照してください。 

この状態で⑩の操作を完了させると，インテリジェント機能ユ

ニットはコマンドパラメータをデフォルトで動作開始します。

↓ 

（次のページへ） 
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（前ページより） 

↓ 

 

⑨  Next ボタンをクリックすると，ヘッドユニットのオンライン

ユニット交換モードを解除します。 

 

(a) Next ボタンをクリックした場合は，下記の処理が行われ

ます。 

・ヘッドユニットはオンラインユニット交換モードを解除さ

れます。 

・入出力データのリフレッシュなどを再開します。 
 

(b) Next ボタンをクリックした後，各ユニットが下記の状態

になっていることを確認してください。 

・ヘッドユニットのREL. LEDが消灯 

・交換したスライスユニットのRUN LEDが点灯 

・“System Monitor”画面にてモニタ中の場合，オンライン

ユニット交換を行うスライスユニットの“Module Status”

が白色に変化 

 

(c)ヘッドユニットのオンラインユニット交換モードを解除で

きなかった場合，ヘッドユニットのREL. LEDおよびERR. LED

が点灯します。 

エラー内容を確認し，処置を行ってください。 

エラーコードの読出し操作およびエラーコードの詳細は

ヘッドユニットのマニュアルを参照してください。 

 

オンラインユニット交換を中断する場合は， Cancel ボタンを

クリックします。 

 

(a) Cancel ボタンをクリックし，オンラインユニット交換を

中断した場合は，オンラインユニット交換再開時の①の操作

で，中断前と同一のスライスユニットを選択し，オンライン

ユニット交換を完了させてください。 

異なるスライスユニットを選択した場合，エラーが発生しま

す。 

↓  

⑩ 左記画面が表示されるとオンラインユニット交換の完了です。

 Finish ボタンをクリックしてください。 

↓ 

（完  了） 
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サービスネットワーク（三菱電機システムサービス(株)） 
 

北海道支店

(011)890－7515

新潟機器サービスステーション

(025)241-7261

北陸支店

(076)252－9519

京滋機器サービスステーション

(075)611－6211

関西機電支社

(06)6458－9728

姫路機器サービスステーション

(0792)81－1141

中四国支社

(082)285－2111

北日本支社

(022)238－1761

東京機電支社

(03)3454－5521

神奈川機器サービスステーション

(042)779－9711

関東機器サービスステーション

(048)652－0378

静岡機器サービスステーション

(054)287－8866

中部支社

(052)722－7601

四国支店

(087)831－3186

倉敷機器サービスステーション

(086)448－5532

九州支社

(092)483－8208

長崎機器サービスステーション

(095)834-1116

 
 

 

 

 

 

 

 

Microsoft，Windows，Windows NTは，米国Microsoft Corporationの米国およびその他の国における登録商標です。 
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PC98-NXは，日本電気株式会社の登録商標です。 

その他，本文中における会社名，商品名は，各社の商標または登録商標です。 
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