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This entry is from the Siemens Industry Online Support. The general terms of use 
(http://www.siemens.com/terms_of_use) apply. 
 

Security 
informa-
tion 

Siemens provides products and solutions with industrial security functions that 
support the secure operation of plants, solutions, machines, equipment and/or 
networks. They are important components in a holistic industrial security 
concept. With this in mind, Siemens’ products and solutions undergo continuous 
development. Siemens recommends strongly that you regularly check for 
product updates. 

For the secure operation of Siemens products and solutions, it is necessary to 
take suitable preventive action (cell protection concept, for example) and 
integrate each component into a holistic, state-of-the-art industrial security 
concept.  Third-party products that may be in use should also be considered.  
For more information about industrial security, visit 
http://www.siemens.com/industrialsecurity. 

To stay informed about product updates as they occur, sign up for a product-
specific newsletter. For more information, visit 
http://support.automation.siemens.com. 

 

http://www.siemens.com/terms_of_use
http://www.siemens.com/industrialsecurity
http://support.automation.siemens.com/
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1 Introduction 
This document shows you how to exchange data between an S7-1200 and an S7-
300 using S7 Communication. 
For this the SIMATIC S7-300 is configured and programmed in STEP 7 V5.5 SP3. 
It sets up the S7 connection actively. 
The SIMATIC S7-1200 is configured and programmed in STEP 7 V13 (TIA Portal). 



2 Configuration and Programming of the SIMATIC S7-1200 in STEP 7 V13 (TIA Portal) 
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2 Configuration and Programming of the 
SIMATIC S7-1200 in STEP 7 V13 
(TIA Portal) 
You configure and program the SIMATIC S7-1200 in STEP 7 V13 (TIA Portal). 
Then you create the user program and define which data is to be exchanged with 
the S7-300 via the S7 connection. 

2.1 Creating a Project 

In Windows, select the menu "Start > All Programs > Siemens Automation > TIA 
Portal V13" to start the TIA Portal. 
In the Portal View, select the "Create new project" action. 
Enter the project name in the appropriate field. 
Figure 2-1 

 
 
Click the "Create" button to create a new project. 
Figure 2-2 
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Use the "Project View" link to switch to the Project View. 
Figure 2-3 

 

2.2 Configuring the Hardware 

Add a SIMATIC S7-1200 
In the project tree, double-click the "Add new device" item. The "Add new device" 
dialog opens. 
Figure 2-4 
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In the working area, click the "Controllers" button. 
Go to "Controllers > SIMATIC S7-1200 > CPU" and select the required controller. 
Click the "OK" button to add the selected S7-1200 CPU to your project. 
 
Figure 2-5 

 
 

Define IP address and assign subnet 
In the project tree, double-click the "Devices & networks" item. The Devices and 
Networks editor opens. 
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Figure 2-6 

 
 
In the Network View or Device View of the Devices and Networks editor you mark 
the S7-1200 CPU. 
In the inspector window you switch to the "Properties" tab. Go to the "General" tab 
and in the area navigation you select the "PROFINET interface" item. 
In this example you enter the IP address 172.16.43.20 and the subnet mask 
255.255.0.0 for the PROFINET interface of the S7-1200 CPU. 
Then assign a subnet to the PROFINET interface. Click the "Add new subnet" 
button to insert a new subnet. 
Figure 2-7 
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After entering the IP address and the subnet mask and assigning the subnet, in the 
navigation area of the "General" tab you select the "Protection" item.  
Enable the "Permit Access with PUT/GET communication from remote partner 
(PLC, HMI, OPC …)" function. 
 
Figure 2-8 

 
 
The connection between the subnet, PN/IE_1, for example, and the S7-1200 is 
now displayed in the Network View of the Devices and Networks editor. 

2.3 Creating a User Program 
In the user program of the S7-1200 CPU you add the data blocks for saving the 
Send and Receive data. 

Add data block for saving the Send data 
In the project tree you mark the device folder of the S7-1200 CPU. The device 
folder contains structured objects and actions that belong to the device. 
In the device folder you navigate to the "Program blocks" subfolder and double-
click the "Add new block" action. The "Add new block" dialog opens. 
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Figure 2-9 

 
 
Click the "Data block (DB)" button. Enter the name of the data block and enable the 
"Automatic" option to assign the number of the data block automatically. If you 
enable the "Manual" option, you can assign the number of the data block manually. 
Apply the settings with "OK". 
The data block DB1 "SEND_DATA" is created in this example for saving the Send 
data. 
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Figure 2-10 

 
 
In the Properties of the data block, under "Attributes" you disable the "Optimized 
block access" function. 
Data blocks with standard access have a fixed structure. The data elements in the 
declaration include both symbolic names and a fixed address in the block. The 
address is displayed in the "Offset" column. You can address the variables in this 
block both symbolically and absolutely. 
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Figure 2-11 

 
 
In DB1 "SEND_DATA" you define the static variable "SEND_DATA" of the data 
type Array[0..99] of Byte. 
Figure 2-12 

 
 

Add data block for saving the Receive data 
Add another data block for saving the Receive data. 
In the "Add new block" dialog you click the "Data block (DB)" button. Enter the 
name of the data block and enable the "Automatic" option to assign the number of 
the data block automatically. If you enable the "Manual" option, you can assign the 
number of the data block manually. 
Apply the settings with "OK". 
The data block DB2 "RECV_DATA" is created in this example for saving the 
Receive data. 
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Figure 2-13 

 
 
In the Properties of the data block, under "Attributes" you disable the "Optimized 
block access" function. 
Data blocks with standard access have a fixed structure. The data elements in the 
declaration include both symbolic names and a fixed address in the block. The 
address is displayed in the "Offset" column. You can address the variables in this 
block both symbolically and absolutely. 
Figure 2-14 
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In DB2 "RECV_DATA" you define the static variable "RECV_DATA" of the data 
type Array[0..99] of Byte. 
Figure 2-15 

 

2.4 Downloading the Hardware Configuration and User 
Program 

Requirements 
You have already assigned the configured IP address 172.16.43.20 and subnet 
mask 255.255.0.0 to the S7-1200 CPU. 

Instructions 
Follow the instructions below to download the configuration and user program into 
the S7-1200 CPU. 
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No. Action 

1.  In the project tree you mark the device folder of the S7-1200 CPU. Click the "Compile" button 
in the toolbar. The hardware configuration and the software of the S7-1200 are compiled. 
 

 
2.  In the project tree you mark the device folder of the S7-1200 CPU. Click the "Download to 

device" button in the toolbar. The "Extended download to device" or "Load preview" dialog 
opens automatically. 
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No. Action 

3.  The "Extended download to device" dialog opens automatically only if the access path from 
the PG/PC to the S7-1200 CPU has to be set. 
• Type of the PG/PC interface: PN/IE 
• PG/PC interface: network card of the PG/PC 
• Connection to subnet: subnet to which the S7-1200 CPU is connected 
From the "Compatible devices in target subnet:" list you select the required S7-1200 CPU and 
click the "Load" button. 
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No. Action 

4.  In the "Load preview" dialog you click the "Load" button to start the loading procedure. 

 
5.  In the "Load results" dialog you enable the "Start all" action and click the "Finish" button to 

terminate the loading procedure. 
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3 Configuration and Programming of the 
SIMATIC S7-300 
You configure and program the SIMATIC S7--300 in STEP 7 V5.5 SP3. 
Then you create the user program and define which data is to be exchanged with 
the S7-300 via the S7 connection. 

3.1 Creating a Project 

In Windows, select the menu "Start > All Programs > SIMATIC > SIMATIC 
Manager" to start the SIMATIC Manager in STEP 7 V5.5 SP3. 
In the SIMATIC Manager, you create a new project with the menu "File > New". 
In the SIMATIC Manager, you add a SIMATIC PC station with the menu "Insert > 
Station > SIMATIC S7-300 Station". 
 
Figure 3-1 

 
 

3.2 Configuring the Hardware 

Create the hardware configuration of the S7-300 station by drag-and-dropping the 
relevant modules like Power Supply, CPU etc. from the hardware catalog into the 
S7-300 profile channel. 
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Define IP address and assign subnet 
Double-click the PROFINET interface of the S7-300 CPU. The Properties dialog of 
the PROFINET interface opens. 
Figure 3-2 

 
 
Click the "Properties" button to change the IP address and subnet mask and assign 
the subnet. 
Figure 3-3 
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In this example you enter the IP address 172.16.43.21 and the subnet mask 
255.255.0.0. Click the "New" button to insert a new subnet. Select the new subnet 
or another existing subnet. Click the “OK” button to apply the IP address and 
subnet mask and assign the selected subnet to the PROFINET interface of the S7-
300 CPU. 
Figure 3-4 

 
 

Clock memory  
Double-click the S7-300 CPU. The Properties dialog of the S7-300 CPU opens. 
Figure 3-5 
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Switch to the "Cycle/Clock Memory" tab and enable, for example, the memory byte 
0 as clock marker. 
Apply the settings with "OK". 
 
Figure 3-6 

 
 
Click the "Save and Compile" button to save and compile the configuration of the 
SIMATIC S7-300. 
Figure 3-7 
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3.3 Configuring the S7 Connection 

In the SIMATIC Manager you open the "NetPro" tool via the menu "Options > 
Configure Network". In "NetPro" you configure the S7 connection for the S7-300 
CPU. 
Figure 3-8 

 
 
Mark the CPU in the SIMATIC S7-300 station. Open the "Insert New Connection" 
dialog via the menu "Insert > New Connection". In this example you insert an 
unspecified S7 connection. 
Figure 3-9 

 
 

 

 



3 Configuration and Programming of the SIMATIC S7-300 
 

 

S7 communication between SIMATIC S7-1200 and SIMATIC S7-300 
Entry ID: ID number,    V1.0,    05/2014   23 
 


 S

ie
m

en
s 

AG
 2

01
4 

Al
l r

ig
ht

s 
re

se
rv

ed
 

Select the entry "(Unspecified)" under Connection Partner. 
Select "S7 connection" as the connection type. 
Click "Apply". The Properties dialog of the S7 connection opens. 
Figure 3-10 
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The S7-300 CPU sets up the S7 connection actively.  
Enter the IP address of the communication partner. In this example you enter the 
IP address of the S7-1200 station. 
You specify the local ID of the connection in the user program at the input 
parameter ID of the function blocks FB15 "PUT" and F14 "GET". 
Click the "Address Details..." button. The "Address Details" dialog opens. 
Figure 3-11 
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Enter the Rack/Slot of the communication partner. The S7-1200 CPU uses Rack 0 
and Slot 1. For the Connection Source (hex) you select 03, because the S7 
connection is configured unilaterally only in the S7-300 CPU. With these settings 
the TSAP 03.01 is used for the S7 connection in the communication partner. 
Apply the settings with "OK". 
 
Figure 3-12 

 
 
In NetPro, mark the CPU in the SIMATIC S7-300 station. The connection table 
shows all the connections configured for the CPU. 
 
Figure 3-13 
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In NetPro you mark the S7-300 station. In the toolbar you click the "Save and 
Compile" button to save and compile the connection configuration. 
 
Figure 3-14 

 
 

3.4 Creating a User Program 

In the user program of the S7-300 CPU you call the function blocks FB15 "PUT" 
and FB14 "GET. 
The function blocks FB15 "PUT" and FB14 "GET" are located in the Standard 
Library under "Communication Blocks > Blocks". Copy the function blocks from the 
Standard Library and insert them in your STEP 7 project. 
The figure below shows the block calls in the S7-300 and S7-1200 CPUs. 
 
Figure 3-15 

Main
[OB 1]

SEND_DATA
[DB 11]

- PUT
- GET

RECV_DATA
[DB 12]

SEND_DATA
[DB 1]

RECV_DATA
[DB 2]

Write data

Read data

User program System blocks Data blocks Data blocks

S7-300 CPU S7-1200 CPU
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3.4.1 FB15 "PUT" 

You use FB15 "PUT" to write data to the S7-1200 CPU. 
Figure 3-16 

 
 
FB15 "PUT" has the following input parameters. 
Table 3-1 

Input parameters Data type Description 

REQ BOOLEAN Request control parameter, enables data 
transfer on a rising edge 
In this example the job to write the data is 
enabled via the clock memory 
M0.5 "ClockMemory". 

ID WORD Reference to the local connection description 
(preset by the connection configuration in STEP 
7) 
In this example the ID = w#16#1 is preset by the 
configuration connection (see Figure 3-1). 

ADDR_1 ANY Pointer to the area to be written to in the partner 
CPU (Receive data area in the partner CPU, 
here S7-1200 CPU). 
More information about the Receive data area in 
the S7-1200 CPU is available in section 3.4.3. 

SD_1 ANY Pointer to the area in your own CPU which 
contains the data to be sent (Send data area in 
your own CPU, 
here S7-300 CPU). 
More information about the Send data area in 
the S7-300 CPU is available in section 3.4.2. 
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FB15 "PUT" has the following output parameters. 
Table 3-2 

Output parameters Data type Description 

DONE BOOLEAN State parameter DONE: 
0 = Job not yet started or is still being executed 
1 = Job executed error-free 

ERROR BOOLEAN State parameters ERROR and STATUS: 
• ERROR = 0: 

– STATUS = 0000(hex): neither warning 
nor error 

– STATUS <> 0000(hex): warning, 
STATUS provides detailed information 

• ERROR = 1: 
A fault has occurred. STATUS provides detailed 
information about the type of error. 

STATUS WORD 

3.4.2 Send data area in the S7-300 CPU 

In the S7-300 CPU the Send data written to the S7-1200 CPU is stored in data 
block DB11 "SEND_DATA". 
In this example 10 bytes of data starting at address 0 are written from DB11 
"SEND_DATA" to the S7-1200 CPU. 

3.4.3 Receive data area in the S7-1200 CPU 

In the S7-1200 CPU the received data is stored in data block DB2 "RECV_DATA". 
In this example 10 bytes of data are stored in DB2 "RECV_DATA" starting at 
address 0. 

3.4.4 Error evaluation of the Write job 

If the Write job does not terminate successfully, in other words ERROR =1, the 
value of the output parameter STATUS is stored in 
MW112 "PUT_STATUS_SAVE". 
 
Figure 3-17 
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3.4.5 FB14 "GET" 

You use FB14 "GET" to read data from the S7-1200 CPU. 
Figure 3-18 

 
 
FB14 "GET" has the following input parameters. 
Table 3-3 

Input parameters Data type Description 

REQ BOOLEAN Request control parameter, enables data 
transfer on a rising edge 
In this example the job to read the data is 
enabled via the clock memory 
M0.5 "ClockMemory". 

ID WORD Reference to the local connection description 
(preset by the connection configuration in STEP 
7) 
In this example the ID = w#16#1 is preset by the 
configuration connection (see Figure 3-1). 

ADDR_1 ANY Pointer to the area to be read in the partner 
CPU (Send data area in the partner CPU, here 
S7-1200 CPU). 
More information about the Send data area in 
the S7-1200 CPU is available in the section 
3.4.7. 

RD_1 ANY Pointer to the area in your own CPU in which 
the read data is stored  
(Receive data area in your own CPU, 
here S7-300 CPU). 
More information about the Receive data area in 
the S7-300 CPU is available in the section 
3.4.6.  
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FB14 "GET" has the following output parameters. 
Table 3-4 

Output parameters Data type Description 

NDR BOOLEAN State parameter NDR: 
0 = Job not yet started or is still being executed 
1 = Job executed error-free 

ERROR BOOLEAN State parameters ERROR and STATUS: 
• ERROR = 0: 

– STATUS = 0000(hex): neither warning 
nor error 

– STATUS <> 0000(hex): warning, 
STATUS provides detailed information 

• ERROR = 1: 
A fault has occurred. STATUS provides detailed 
information about the type of error. 

STATUS WORD 

3.4.6 Receive data area in the S7-300 CPU 

In the S7-300 CPU the Receive data read from the S7-1200 CPU is stored in data 
block DB12 "RECV_DATA". 
In this example 10 bytes of data are stored in DB12 "RECV_DATA" starting at 
address 0. 

3.4.7 Send data area in the S7-1200 CPU 

In the S7-1200 CPU the data read from the S7-300 CPU is stored in data block 
DB1 "SEND_DATA". 
In this example 10 bytes of data starting at address 0 are read from DB1 
"SEND_DATA" of the S7-1200 CPU. 

3.4.8 Error evaluation of the Read job 

If the Read job does not terminate successfully, in other words ERROR =1, the 
value of the output parameter STATUS is stored in 
MW122 "GET_STATUS_SAVE". 
 
Figure 3-19 
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3.5 Downloading the Hardware Configuration, Connection 
Configuration and User Program 

Requirements 
You have already assigned the configured IP address 172.16.43.21 and subnet 
mask 255.255.0.0 to the S7-300 CPU. 

Instructions 
Follow the instructions below to download the configuration, the connection 
configuration and the user program into the S7-300 CPU. 

Table 3-5 

No. Description 

1.  In the SIMATIC Manager, you select the menu "Options > Set PG/PC Interface". The "Set 
PG/PC Interface" dialog opens. 
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No. Description 

2.  As access point for the application you set the network card with TCP/IP protocol via which 
the SIMATIC Field PG is connected to the S7-300 CPU and via which you access the S7--300 
CPU. 
Apply the settings with "OK". 
 

 
3.  In the SIMATIC Manager you mark the SIMATIC S7-300 station. 

In the toolbar you click the "Load" button. This loads the configuration, the connection 
configuration and the user program into the S7-300 CPU. 
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4 Operation and Monitoring 
Operation and monitoring is done via a variable table in STEP 7 V5.5 SP3 and in 
STEP 7 V13 (TIA Portal). 

4.1 Writing Data to the S7-1200 CPU 

Monitor variables 
In STEP 7 V5.5 SP3 you can monitor and modify the Send and Receive data of the 
S7-300 CPU in the variable table. 
In the toolbar of the variable table you click the "Monitor Variable" button. The 
"Status value" column displays the current values in the Send data area (DB11) 
and Receive data area (DB12). 
Figure 4-1 

 
 

Write data 
In the "Modify value" column you enter the values for the Send data area (DB11) 
which are to be written to the Receive data area of the S7-1200 CPU. In the toolbar 
you click the "Modify variable" button to transfer the modify values to the Send data 
area of the S7-300 CPU and write them to the S7-1200 CPU. 
 
 
 

 

 



4 Operation and Monitoring 
 

 

S7 communication between SIMATIC S7-1200 and SIMATIC S7-300 
Entry ID: ID number,    V1.0,    05/2014   34 
 


 S

ie
m

en
s 

AG
 2

01
4 

Al
l r

ig
ht

s 
re

se
rv

ed
 

Figure 4-2 

 
 
In STEP 7 V13 (TIA Portal) you can monitor and modify the Send and Receive 
data of the S7-1200 CPU in the variable table. 
In the toolbar of the variable table you click the "Monitor All" button. The "Monitor 
value" column displays the current values in the Send data area (DB1) and 
Receive data area (DB2). This permits you to check whether the data written from 
the S7-300 CPU has arrived in the Receive data area (DB2) of the S7-1200 CPU. 
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Figure 4-3 

 

4.2 Reading Data from the S7-1200 CPU 

Monitor variables 
In STEP 7 V13 (TIA Portal) you can monitor and modify the Send and Receive 
data of the S7-1200 CPU in the variable table. 
In the toolbar of the variable table you click the "Monitor All" button. The "Monitor 
value" column displays the current values in the Send data area (DB1) and 
Receive data area (DB2). 
 

 

 



4 Operation and Monitoring 
 

 

S7 communication between SIMATIC S7-1200 and SIMATIC S7-300 
Entry ID: ID number,    V1.0,    05/2014   36 
 


 S

ie
m

en
s 

AG
 2

01
4 

Al
l r

ig
ht

s 
re

se
rv

ed
 

Figure 4-4 

 
 

Read data 
In the "Modify value" column you enter the values for the Send data area which are 
read from the S7-300 CPU and stored in the Receive data area of the S7-300 
CPU. In the toolbar you click the "Modify all enabled values once and immediately" 
button to transfer the modify values to the Send data area of the S7-1200 CPU. 
Figure 4-5 
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In STEP 7 V5.5 SP3 you can monitor and modify the Send and Receive data of the 
S7-300 CPU in the variable table. 
In the toolbar of the variable table you click the "Monitor Variable" button. The 
"Status value" column displays the current values in the Send data area (DB11) 
and Receive data area (DB12). This permits you to check whether the data read 
from the S7-1200 CPU has arrived in the Receive data area (DB12) of the S7-300 
CPU. 
Figure 4-6 
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